Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Word 2007 Inserting Table: Border Outside Text Area


  • Please log in to reply

#1
rphox2003

rphox2003

    Member

  • Member
  • PipPip
  • 15 posts
Every time I insert a table in Word 2007 the table borders (both left and right) are outside the text area of the document. Even if I insert a table with a single cell on a single row - the borders are outside the text area.
  • How can I fix all tables in a document simultaneously?
  • How can I setup the default so the table borders match the text area?
Thanks.
  • 0

Advertisements


#2
Vino Rosso

Vino Rosso

    Visiting Staff

  • Visiting Consultant
  • 235 posts
Hi

Have a read through >this article< by CyberText on Using Table Styles

I think you need to cover your second question first with "Setting a table style as the default for new tables" then your first question with "Applying a table style to an existing table"
  • 0

#3
rphox2003

rphox2003

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Thanks, Vino. That helped - to a point.

When I select the table style from the ribbon and go to the Modify options, the only option I can see that might help is in:
Modify Styles > Format > Table Properties > Table

In the Alignment section, I've selected left-aligned, which solves the left border problem. But the right border is still out of the text area. I also understand setting the Preferred width in the Size section can help, but this section is disabled.

I've even tried creating a new style - with the same results. The right border of the table is outside the text area.

Any suggestions? Thanks again.

Edited by rphox2003, 04 May 2011 - 11:42 PM.

  • 0

#4
Vino Rosso

Vino Rosso

    Visiting Staff

  • Visiting Consultant
  • 235 posts
Just checking...

Create a table, right-click > Table Properties
On the Table tab, click Options...
Is 'Automatically resize to fit contents' ticked?

Also, Table > Insert Table
Is 'Fixed column width' set to Auto?
  • 0

#5
rphox2003

rphox2003

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts

Just checking...

Create a table, right-click > Table Properties
On the Table tab, click Options...
Is 'Automatically resize to fit contents' ticked?

Also, Table > Insert Table
Is 'Fixed column width' set to Auto?


Are these options in Word 2007?
  • 0

#6
Vino Rosso

Vino Rosso

    Visiting Staff

  • Visiting Consultant
  • 235 posts
Yep. 'Table' is on the Insert tab of the ribbon.
  • 0

#7
rphox2003

rphox2003

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Thanks for your help.

  • Auto resize to fit contents is not selected.
  • Fixed column width is set to Auto.

Please look at the attached graphic. This demonstrates how Word inserts a table. Notice the right margin is outside the text area?

I know it's a little thing, but I'm a technical writer and stuff like this drives me crazy. After years of working with an XML-based authoring tool, I've started at company that uses Word, in which I have little experience.

Thanks again.

Attached Thumbnails

  • InsTable.png

  • 0

#8
Vino Rosso

Vino Rosso

    Visiting Staff

  • Visiting Consultant
  • 235 posts

  • Auto resize to fit contents is not selected.


Try selecting/ticking 'Auto resize to fit contents'.

Any difference when creating a new table?

Edited by Vino Rosso, 09 May 2011 - 01:13 AM.

  • 0

#9
rphox2003

rphox2003

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Nope, no difference.

When I select Autofit Contents, the table opens with almost no width. As I add contents to a cell, the table expands but the line breaks after the right border goes outside the content area of the page.

I read someplace that in the Table Properties > Table dialog box, if I change the Preferred width to Measure in Percent, I can fix the problem. This really does work - I set the Preferred width to 98%. But I have to do this to each table, even new ones. And I seem to remember that when I tried this with some legacy documents, the field was disabled.

There has to be a way to set this without having to go into the table properties for each table.

Thanks again for the effort.
  • 0

#10
Vino Rosso

Vino Rosso

    Visiting Staff

  • Visiting Consultant
  • 235 posts
Create a new table (that goes outside the right margin)
Click inside the table and go to the Table Tools > Layout tab
Click the large AutoFit icon then click AutoFit Window

Does the table size reduce or does it stay with the right size outside the right edge?

If it stays outside the right edge, create a new blank document
On the Page Layout tab, click Margins. Is this set to Normal?
Is the right margin set inside the right edge of the page?
  • 0

#11
rphox2003

rphox2003

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Does the table size reduce or does it stay with the right size outside the right edge?
After clicking Autofit Window, the right border remains outside the text area and the left border moves to outside the left text area.

On the Page Layout tab, click Margins. Is this set to Normal?
Yes

Is the right margin set inside the right edge of the page?
Yes, it is aligned with the right side of the text area.

Please see attached.

Attached Thumbnails

  • PageSetup.png

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP