Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Browser Loading & Performance Problems


  • Please log in to reply

#1
capper

capper

    Member

  • Member
  • PipPip
  • 64 posts
I am running 2 laptops at present; (1) a Panasonic with XP and (2) an Acer with Windows 7. I can run applications like Metatrader and skype on my Panasonic no problem, but recently, I can't seem to load any of my browsers (I have Firefox & Explorer). They simply will not load. The "egg timer" on the cursor comes on but it simply will not load the browser at anymore.

In addition, my Acer's performance has been terrible lately. Whenever I use either of the 2 browsers I mentioned above, they are slower than usual and require 2-4 clicks of the mouse before I am able to pull up a web page etc. I use SuperAntiSpyware occasionally. I am tempted to restore the machine to a previous date (such as factory) but I am hesitant to do so as my other laptop isn't functioning properly now!
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP