Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Invalid IP address after removing SECURITY PROTECTION virus


  • Please log in to reply

#1
KDHoost

KDHoost

    Member

  • Member
  • PipPip
  • 16 posts
Recently, I uninstalled my copy of AVG Free due to it conflicting with certain test-preparation software that I was using, but after I completed the test I failed to reinstall it. Consequently, it seems, I picked up several pieces of malware, including a google redirect and a program that calls itself "Security Protection." I googled a solution to fix it, which recommended booting in Safe Mode w/ Networking & running Malwarebytes. I did this, and after installation, Malwarebytes crashed, saying the file could not be found. Further examination revealed that the files were gone, as if they'd been click-and-dragged to the recyle bin.

I tried and retried this a couple of times, and it did finally run and remove around 10 pieces of malware, only to crash and uninstall itself again., installed Avira and couldn't get it to work, installed AVG & couldn't get it to work, and *finally* used avast. All four were downloaded either off of their official website or cnet.com. Anyways, I eventually was able to download Malwarebytes and Avast Antivirus which seems to have helped with the virus and other problems, but now my emachine netbook will not fully connect to the internet in our building. It recognizes that it is there but gets stuck at "Acquiring network address." It is set to obtain the IP address and DNS server address automatically, but still will not connect. When I click on status under support it says:

Address type: Invalid IP Address
IP Adress: 0.0.0.0
Subnet Mask: 0.0.0.0
The Default Gateway is blank.

Any help would be great. I have no clue what kind of router we have as it is shared between our apartment building, but no other computer in our house or our Wii is having problems getting online.

Thank you

Edited by KDHoost, 31 August 2011 - 04:39 PM.

  • 0

Advertisements


#2
RKinner

RKinner

    Malware Expert

  • Expert
  • 20,029 posts
  • MVP
Click on the Avast ball. Then click on Additional Protections then on AutoSandbox then on Settings then uncheck Enable AutoSandbox. OK

ComboFix

:!: If you have a previous version of Combofix.exe, delete it and download a fresh copy. :!:

:!: It must be saved to your desktop, do not run it :!:

:!: Disable your Antivirus software when downloading or running Combofix.==>Right click on the Avast Ball and select Avast! Shields Control and Disable Until Computer is Restarted ( I suppose you will have to download CF on one machine and transfer it to the desktop of the other via CD or USB. Make sure the anti-virus is off on the good machine while downloading and transfering CF.


Download and Save this file -- to your Desktop -- from either of these two sources:
http://download.blee...Bs/ComboFix.exe
http://subs.geekstogo.com/ComboFix.exe

Rightclick on ComboFix and select Run As Administrator to start the program.



* :!: Important: Have no other programs running. Your Task Bar should be clear of any program entries including your Browser.


* A window may open with a series of Disclaimers. Accept the Disclaimers to start the fix.


A caution - Do not run Combofix more than once. Do not touch your mouse/keyboard until the scan has completed, as this may cause the process to stall or your computer to lock. The scan will temporarily disable your desktop, and if interrupted may leave your desktop disabled. If this occurs, please reboot to restore the desktop. Even when ComboFix appears to be doing nothing, look at your Drive light. If it is flashing, Combofix is still at work.

A file will be created at => C:\Combofix.txt. I'll need to see that in your reply.

Start, (All) Programs, Accessoriesw then Command Prompt (if Vista or Windows 7 you need to right click on Command Prompt and Run As Administrator). Type with an Enter after each line:

For your network issue:

net start

(Check the output. Is DHCP running? IF not: right click on (My) Computer and select Manage then Services and Applications then Services. Find the DHCP or DHCP Client service and right click on it and select Properties. Make sure the Startup Type says Automatic or Delayed Automatic (if not change it and Apply) see if it will Start. What error do you get? Look under Dependencies tab. What does it depend on?)

ipconfig /renew

(what error do you get?)

Ron
  • 0

#3
KDHoost

KDHoost

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
Thank you! Here is the combofix log results:

ComboFix 11-08-31.04 - Kylie 08/31/2011 22:16:43.1.2 - x86
Microsoft Windows XP Home Edition 5.1.2600.3.1252.1.1033.18.1014.712 [GMT -4:00]
Running from: c:\documents and settings\Administrator\Desktop\ComboFix.exe
AV: avast! Antivirus *Disabled/Updated* {7591DB91-41F0-48A3-B128-1A293FD8233D}
.
WARNING -THIS MACHINE DOES NOT HAVE THE RECOVERY CONSOLE INSTALLED !!
.
.
((((((((((((((((((((((((((((((((((((((( Other Deletions )))))))))))))))))))))))))))))))))))))))))))))))))
.
.
c:\documents and settings\All Users\Application Data\ptyt.exe
c:\documents and settings\All Users\Application Data\waby.exe
c:\documents and settings\All Users\Application Data\ycvo.exe
c:\documents and settings\All Users\Application Data\yjyh.exe
c:\documents and settings\Kylie\biysqldmli.tmp
c:\documents and settings\Kylie\Local Settings\Application Data\{54551A21-1482-4985-902C-CE84F29298AD}
c:\documents and settings\Kylie\Local Settings\Application Data\{54551A21-1482-4985-902C-CE84F29298AD}\chrome.manifest
c:\documents and settings\Kylie\Local Settings\Application Data\{54551A21-1482-4985-902C-CE84F29298AD}\chrome\content\overlay.xul
c:\documents and settings\Kylie\Local Settings\Application Data\{54551A21-1482-4985-902C-CE84F29298AD}\install.rdf
c:\documents and settings\Kylie\Local Settings\Application Data\cgay.exe
c:\documents and settings\Kylie\Local Settings\Application Data\nubs.exe
c:\documents and settings\Kylie\Local Settings\Application Data\pexv.exe
c:\documents and settings\Kylie\Local Settings\Application Data\wnqx.exe
c:\documents and settings\Kylie\udpcrawl.tmp
c:\windows\$NtUninstallKB61088$
c:\windows\$NtUninstallKB61088$\2702313174
c:\windows\$NtUninstallKB61088$\746011944\{1B372133-BFFA-4dba-9CCF-5474BED6A9F6}
c:\windows\$NtUninstallKB61088$\746011944\click.tlb
c:\windows\$NtUninstallKB61088$\746011944\L\snrtcsyh
c:\windows\$NtUninstallKB61088$\746011944\loader.tlb
c:\windows\$NtUninstallKB61088$\746011944\U\@00000001
c:\windows\$NtUninstallKB61088$\746011944\U\@000000c0
c:\windows\$NtUninstallKB61088$\746011944\U\@000000cb
c:\windows\$NtUninstallKB61088$\746011944\U\@000000cf
c:\windows\$NtUninstallKB61088$\746011944\U\@80000000
c:\windows\$NtUninstallKB61088$\746011944\U\@800000c0
c:\windows\$NtUninstallKB61088$\746011944\U\@800000cb
c:\windows\$NtUninstallKB61088$\746011944\U\@800000cf
c:\windows\system32\_000006_.tmp.dll
c:\windows\system32\_000007_.tmp.dll
c:\windows\system32\_000008_.tmp.dll
c:\windows\system32\_000009_.tmp.dll
c:\windows\system32\_000010_.tmp.dll
c:\windows\system32\_000023_.tmp.dll
c:\windows\system32\_000024_.tmp.dll
c:\windows\system32\_000025_.tmp.dll
c:\windows\system32\_000026_.tmp.dll
c:\windows\system32\714527112
c:\windows\system32\c_39651.nls
.
Infected copy of c:\windows\system32\drivers\netbt.sys was found and disinfected
Restored copy from - The cat found it :)
.
((((((((((((((((((((((((( Files Created from 2011-08-01 to 2011-09-01 )))))))))))))))))))))))))))))))
.
.
2011-08-27 19:01 . 2011-07-04 11:36 309848 ----a-w- c:\windows\system32\drivers\aswSP.sys
2011-08-27 19:01 . 2011-07-04 11:32 19544 ----a-w- c:\windows\system32\drivers\aswFsBlk.sys
2011-08-27 01:03 . 2011-08-27 01:03 -------- d-----w- c:\windows\system32\NtmsData
2011-08-25 02:55 . 2011-08-27 00:44 43408 --sha-w- c:\windows\system32\c_39651.nl_
2011-08-25 02:18 . 2011-08-27 19:05 -------- d-----w- c:\documents and settings\Administrator
2011-08-16 19:05 . 2011-08-16 19:05 404640 ----a-w- c:\windows\system32\FlashPlayerCPLApp.cpl
2011-08-14 17:54 . 2011-08-27 00:07 134104 ----a-w- c:\program files\Mozilla Firefox\components\browsercomps.dll
2011-08-14 17:54 . 2011-08-27 00:07 89048 ----a-w- c:\program files\Mozilla Firefox\libEGL.dll
2011-08-14 17:54 . 2011-08-27 00:07 478168 ----a-w- c:\program files\Mozilla Firefox\libGLESv2.dll
2011-08-14 17:54 . 2011-08-27 00:07 15832 ----a-w- c:\program files\Mozilla Firefox\mozalloc.dll
2011-08-14 17:54 . 2011-08-27 00:07 785368 ----a-w- c:\program files\Mozilla Firefox\mozsqlite3.dll
2011-08-14 17:54 . 2011-08-27 00:07 1846232 ----a-w- c:\program files\Mozilla Firefox\mozjs.dll
2011-08-14 17:54 . 2010-01-01 08:00 2106216 ----a-w- c:\program files\Mozilla Firefox\D3DCompiler_43.dll
2011-08-14 17:54 . 2010-01-01 08:00 1998168 ----a-w- c:\program files\Mozilla Firefox\d3dx9_43.dll
2011-08-12 00:02 . 2011-08-12 00:02 -------- d-----w- c:\program files\StreamTorrent 1.0
2011-08-04 15:56 . 2011-08-04 15:56 -------- d-----w- C:\$AVG
2011-08-04 15:48 . 2011-08-16 18:46 -------- d-----w- c:\documents and settings\All Users\Application Data\AVG10
2011-08-04 15:48 . 2011-08-16 18:45 -------- d-----w- c:\windows\system32\drivers\AVG
2011-08-04 15:48 . 2011-08-04 15:48 -------- d-----w- c:\program files\AVG
2011-08-04 15:43 . 2011-08-04 15:43 -------- d--h--w- c:\documents and settings\All Users\Application Data\Common Files
2011-08-04 15:43 . 2011-08-27 00:47 -------- d-----w- c:\documents and settings\All Users\Application Data\MFAData
2011-08-04 15:33 . 2011-08-04 15:33 -------- d-----w- c:\windows\system32\Adobe
.
.
.
(((((((((((((((((((((((((((((((((((((((( Find3M Report ))))))))))))))))))))))))))))))))))))))))))))))))))))
.
2011-08-27 00:07 . 2009-11-06 16:26 455680 ----a-w- c:\windows\system32\drivers\mrxsmb.sys
2011-08-27 00:07 . 2011-08-14 17:54 134104 ----a-w- c:\program files\mozilla firefox\components\browsercomps.dll
2010-06-25 17:53 203776 --sh--w- c:\windows\system32\unrar.exe
.
.
((((((((((((((((((((((((((((((((((((( Reg Loading Points ))))))))))))))))))))))))))))))))))))))))))))))))))
.
.
*Note* empty entries & legit default entries are not shown
REGEDIT4
.
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\URLSearchHooks]
"{bf7380fa-e3b4-4db2-af3e-9d8783a45bfc}"= "c:\program files\uTorrentBar\tbuTo0.dll" [2010-12-09 3911776]
.
[HKEY_CLASSES_ROOT\clsid\{bf7380fa-e3b4-4db2-af3e-9d8783a45bfc}]
.
[HKEY_LOCAL_MACHINE\~\Browser Helper Objects\{30F9B915-B755-4826-820B-08FBA6BD249D}]
2010-12-09 17:51 3911776 ----a-w- c:\program files\ConduitEngine\ConduitEngine.dll
.
[HKEY_LOCAL_MACHINE\~\Browser Helper Objects\{bf7380fa-e3b4-4db2-af3e-9d8783a45bfc}]
2010-12-09 17:51 3911776 ----a-w- c:\program files\uTorrentBar\tbuTo0.dll
.
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Toolbar]
"{bf7380fa-e3b4-4db2-af3e-9d8783a45bfc}"= "c:\program files\uTorrentBar\tbuTo0.dll" [2010-12-09 3911776]
"{30F9B915-B755-4826-820B-08FBA6BD249D}"= "c:\program files\ConduitEngine\ConduitEngine.dll" [2010-12-09 3911776]
.
[HKEY_CLASSES_ROOT\clsid\{bf7380fa-e3b4-4db2-af3e-9d8783a45bfc}]
.
[HKEY_CLASSES_ROOT\clsid\{30f9b915-b755-4826-820b-08fba6bd249d}]
.
[HKEY_LOCAL_MACHINE\software\microsoft\windows\currentversion\explorer\shelliconoverlayidentifiers\00avast]
@="{472083B0-C522-11CF-8763-00608CC02F24}"
[HKEY_CLASSES_ROOT\CLSID\{472083B0-C522-11CF-8763-00608CC02F24}]
2011-07-04 11:43 122512 ----a-w- c:\program files\AVAST Software\Avast\ashShell.dll
.
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
"IAAnotif"="c:\program files\Intel\Intel Matrix Storage Manager\iaanotif.exe" [2008-04-18 178712]
"IgfxTray"="c:\windows\system32\igfxtray.exe" [2008-02-28 141848]
"HotKeysCmds"="c:\windows\system32\hkcmd.exe" [2008-02-28 166424]
"Persistence"="c:\windows\system32\igfxpers.exe" [2008-02-28 137752]
"RTHDCPL"="RTHDCPL.EXE" [2009-08-24 18702336]
"AzMixerSel"="c:\program files\Realtek\Audio\Drivers\AzMixerSel.exe" [2006-07-17 53248]
"Adobe Reader Speed Launcher"="c:\program files\Adobe\Reader 9.0\Reader\Reader_sl.exe" [2009-02-28 35696]
"MSPY2002"="c:\windows\system32\IME\PINTLGNT\ImScInst.exe" [2008-04-14 59392]
"PHIME2002ASync"="c:\windows\system32\IME\TINTLGNT\TINTSETP.EXE" [2008-04-14 455168]
"PHIME2002A"="c:\windows\system32\IME\TINTLGNT\TINTSETP.EXE" [2008-04-14 455168]
"PLFSetL"="c:\windows\PLFSetL.exe" [2008-07-03 94208]
"SynTPEnh"="c:\program files\Synaptics\SynTP\SynTPEnh.exe" [2009-09-03 1557800]
"SunJavaUpdateSched"="c:\program files\Common Files\Java\Java Update\jusched.exe" [2010-02-18 248040]
"snp2uvc"="c:\windows\system32\csnp2uvc.dll" [2009-02-17 196608]
"IMJPMIG8.1"="c:\windows\IME\imjp8_1\IMJPMIG.EXE" [2008-04-14 208952]
"HP Software Update"="c:\program files\HP\HP Software Update\HPWuSchd2.exe" [2007-10-15 49152]
"hpqSRMon"="c:\program files\HP\Digital Imaging\bin\hpqSRMon.exe" [2007-08-22 80896]
"QuickTime Task"="c:\program files\QuickTime\QTTask.exe" [2010-11-29 421888]
"iTunesHelper"="c:\program files\iTunes\iTunesHelper.exe" [2010-12-13 421160]
"AppleSyncNotifier"="c:\program files\Common Files\Apple\Mobile Device Support\AppleSyncNotifier.exe" [2010-12-14 47904]
"avast"="c:\program files\AVAST Software\Avast\avastUI.exe" [2011-07-04 3493720]
"Malwarebytes' Anti-Malware"="c:\program files\Malwarebytes' Anti-Malware\mbamgui.exe" [2011-07-08 449584]
.
c:\documents and settings\All Users\Start Menu\Programs\Startup\
HP Digital Imaging Monitor.lnk - c:\program files\HP\Digital Imaging\bin\hpqtra08.exe [2007-10-14 214360]
.
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal\Wdf01000.sys]
@="Driver"
.
[HKEY_LOCAL_MACHINE\software\microsoft\security center]
"AntiVirusOverride"=dword:00000001
"FirewallOverride"=dword:00000001
.
[HKLM\~\services\sharedaccess\parameters\firewallpolicy\standardprofile]
"DisableNotifications"= 1 (0x1)
.
[HKLM\~\services\sharedaccess\parameters\firewallpolicy\standardprofile\AuthorizedApplications\List]
"%windir%\\Network Diagnostic\\xpnetdiag.exe"=
"%windir%\\system32\\sessmgr.exe"=
"c:\\Program Files\\Windows Live\\Messenger\\wlcsdk.exe"=
"c:\\Program Files\\Windows Live\\Messenger\\msnmsgr.exe"=
"c:\\Program Files\\Windows Live\\Sync\\WindowsLiveSync.exe"=
"c:\\Program Files\\AIM\\aim.exe"=
"c:\\Program Files\\uTorrent\\uTorrent.exe"=
"c:\\Program Files\\HP\\Digital Imaging\\bin\\hpqtra08.exe"=
"c:\\Program Files\\HP\\Digital Imaging\\bin\\hpqste08.exe"=
"c:\\Program Files\\HP\\Digital Imaging\\bin\\hposid01.exe"=
"c:\\Program Files\\HP\\Digital Imaging\\bin\\hpiscnapp.exe"=
"c:\\Program Files\\HP\\Digital Imaging\\bin\\hpqkygrp.exe"=
"c:\\Program Files\\VideoLAN\\VLC\\vlc.exe"=
"c:\\Program Files\\iTunes\\iTunes.exe"=
"c:\\Program Files\\Skype\\Phone\\Skype.exe"=
.
R1 aswSnx;aswSnx;c:\windows\system32\drivers\aswSnx.sys [8/27/2011 3:01 PM 441176]
R1 aswSP;aswSP;c:\windows\system32\drivers\aswSP.sys [8/27/2011 3:01 PM 309848]
R2 aswFsBlk;aswFsBlk;c:\windows\system32\drivers\aswFsBlk.sys [8/27/2011 3:01 PM 19544]
R2 MBAMService;MBAMService;c:\program files\Malwarebytes' Anti-Malware\mbamservice.exe [8/27/2011 1:57 PM 366640]
R3 L1c;NDIS Miniport Driver for Atheros AR8131/AR8132 PCI-E Ethernet Controller;c:\windows\system32\drivers\l1c51x86.sys [11/6/2009 12:27 PM 38912]
R3 MBAMProtector;MBAMProtector;c:\windows\system32\drivers\mbam.sys [8/27/2011 1:57 PM 22712]
S2 Updater Service;Updater Service;c:\program files\eMachines\eMachines Updater\UpdaterService.exe --> c:\program files\eMachines\eMachines Updater\UpdaterService.exe [?]
S3 Ambfilt;Ambfilt;c:\windows\system32\drivers\Ambfilt.sys [11/6/2009 3:14 PM 1684736]
S3 RSUSBSTOR;RtsUStor.Sys Realtek USB Card Reader;c:\windows\system32\drivers\RtsUStor.sys [11/6/2009 3:09 PM 162816]
S3 Rts516xIR;Realtek IR Driver;c:\windows\system32\DRIVERS\Rts516xIR.sys --> c:\windows\system32\DRIVERS\Rts516xIR.sys [?]
.
[HKEY_LOCAL_MACHINE\software\microsoft\windows nt\currentversion\svchost]
HPZ12 REG_MULTI_SZ Pml Driver HPZ12 Net Driver HPZ12
hpdevmgmt REG_MULTI_SZ hpqcxs08 hpqddsvc
.
.
------- Supplementary Scan -------
.
uStart Page = hxxp://homepage.emachines.com/rdr.aspx?b=ACEW&l=0409&m=em250&r=0xph06103335l0464wuh5r4462623q
mStart Page = hxxp://homepage.emachines.com/rdr.aspx?b=ACEW&l=0409&m=em250&r=0xph06103335l0464wuh5r4462623q
uInternet Connection Wizard,ShellNext = "c:\program files\Outlook Express\msimn.exe"
uInternet Settings,ProxyServer = http=127.0.0.1:64061
IE: E&xport to Microsoft Excel - c:\progra~1\MICROS~2\Office12\EXCEL.EXE/3000
TCP: DhcpNameServer = 192.168.2.1
FF - ProfilePath - c:\documents and settings\Kylie\Application Data\Mozilla\Firefox\Profiles\v468s1uk.default\
FF - prefs.js: browser.search.selectedEngine -
FF - prefs.js: browser.startup.homepage - hxxp://www.google.com/ig?hl=en&source=iglk
FF - prefs.js: keyword.URL - chrome://browser-region/locale/region.properties
.
- - - - ORPHANS REMOVED - - - -
.
URLSearchHooks-{A3BC75A2-1F87-4686-AA43-5347D756017C} - (no file)
BHO-{D93CB18B-9EBA-7149-EB58-71381B7D2ADA} - (no file)
Toolbar-{CCC7A320-B3CA-4199-B1A6-9F516DD69829} - (no file)
Notify-98a4b6ef964 - c:\windows\system32\hnetmon32.dll
SafeBoot-26520323.sys
SafeBoot-30954886.sys
SafeBoot-46237978.sys
SafeBoot-99359944.sys
.
.
.
**************************************************************************
.
catchme 0.3.1398 W2K/XP/Vista - rootkit/stealth malware detector by Gmer, http://www.gmer.net
Rootkit scan 2011-08-31 23:16
Windows 5.1.2600 Service Pack 3 NTFS
.
scanning hidden processes ...
.
scanning hidden autostart entries ...
.
scanning hidden files ...
.
scan completed successfully
hidden files: 0
.
**************************************************************************
.
--------------------- DLLs Loaded Under Running Processes ---------------------
.
- - - - - - - > 'explorer.exe'(2656)
c:\windows\system32\WININET.dll
c:\windows\system32\ieframe.dll
c:\windows\system32\webcheck.dll
.
------------------------ Other Running Processes ------------------------
.
c:\program files\AVAST Software\Avast\AvastSvc.exe
c:\windows\RTHDCPL.EXE
c:\windows\system32\igfxsrvc.exe
c:\program files\HP\Digital Imaging\bin\hpqSTE08.exe
c:\program files\HP\Digital Imaging\bin\hpqbam08.exe
c:\program files\HP\Digital Imaging\bin\hpqgpc01.exe
.
**************************************************************************
.
Completion time: 2011-08-31 23:26:30 - machine was rebooted
ComboFix-quarantined-files.txt 2011-09-01 03:26
.
Pre-Run: 19,916,664,832 bytes free
Post-Run: 20,792,598,528 bytes free
.
- - End Of File - - 516A7CBD9858588E419F1A2EF56A62DA


Additionally, the error message when trying to start the DHCP is:
Could not start the DHCP Client service on Local Computer.
Error 1075: The dependency service does not exist or has been marked for deletion.


ipconfig/renew is returning nothing- am I incorrect in running it as a command prompt?
  • 0

#4
RKinner

RKinner

    Malware Expert

  • Expert
  • 20,029 posts
  • MVP
Should be a space between ipconfig and \renew and yes it is from a command Window.

Look in the Dependencies tab for DHCP and tell me what Dependencies it has. The Right click on My Computer and select Manage then Device Manager then View, Show Hidden Devices. Look in the non plug and play devices for the dependencies from DHCP. Do you see a yellow mark? Which one?

Ron
  • 0

#5
KDHoost

KDHoost

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
There are three yellow marks under the Non-Plug and Play Drivers:
catchme, Parport and Serial

I re-did the ipconfig \renew and a command box popped up and then was gone before I could read what it was.

Thanks!
  • 0

#6
RKinner

RKinner

    Malware Expert

  • Expert
  • 20,029 posts
  • MVP
What dependencies did you have for DHCP?

Start, Run, cmd, OK then type:

ipconfig /renew
  • 0

#7
KDHoost

KDHoost

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
When I did the command you told me to do I received this message:

No operation can be performed on Local Area Connection while it has its media disconnected.
An error occurred while renewing interface Wireless Network Connection : The RPC server is unavailable.
  • 0

#8
RKinner

RKinner

    Malware Expert

  • Expert
  • 20,029 posts
  • MVP
That's what you get when DHCP is not running. Since DHCP won't run because a dependency is not running we need to know what dependencies it is missing.

Ron
  • 0

#9
KDHoost

KDHoost

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
Am I correct that there are 3 dependencies and they are: AFD, TCP/IP Protocol Driver and NetBios over Tcpip?
The two on my computer under the dependencies tab are AFD & TCP/IP Protocol Driver
  • 0

#10
RKinner

RKinner

    Malware Expert

  • Expert
  • 20,029 posts
  • MVP
It's not what is usually there that I care about. It is what yours says. We can live without netbt. Look in the device manager again (View, Show Hidden Devices) and under non-plug and play devices see if you can find then two you have.

Ron
  • 0

Advertisements


#11
KDHoost

KDHoost

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
They are both there.
  • 0

#12
RKinner

RKinner

    Malware Expert

  • Expert
  • 20,029 posts
  • MVP
Right click on each of the two dependency devices and select Properties.

Does it say they are working correctly?

IF both are working correctly then does DHCP still say it can't start because of a dependency problem?

Copy the next line:

reg query HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp > \junk.txt

Start, Run, cmd, OK

right click and paste or edit then paste and the line should appear. (You can also type it in if you want to just leave a space before and after query and > ). Hit Enter.

notepad \junk.txt

I need you to save the \junk.txt file to your USB drive then move it back to the good PC and attach it to a Reply.

Also if you could run ipconfig on your good computer and give me the IP address and default gateway that it has I may have a work around to get you on the internet.

Ron
  • 0

#13
KDHoost

KDHoost

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
They were said to be working properly. Here is the junk.txt:


! REG.EXE VERSION 3.0

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp
Type REG_DWORD 0x20
Start REG_DWORD 0x2
ErrorControl REG_DWORD 0x1
ImagePath REG_EXPAND_SZ %SystemRoot%\system32\svchost.exe -k netsvcs
DisplayName REG_SZ DHCP Client
Group REG_SZ TDI
DependOnService REG_MULTI_SZ Tcpip\0Afd\0NetBT\0\0
DependOnGroup REG_MULTI_SZ \0
ObjectName REG_SZ LocalSystem
Description REG_SZ Manages network configuration by registering and updating IP addresses and DNS names.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp\Configurations

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp\Linkage

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp\Parameters

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp\Security

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp\Enum

On the good computer connection:

IP Address - 192.168.2.17
Default Gateway - 192.168.2.1

Thank you
  • 0

#14
RKinner

RKinner

    Malware Expert

  • Expert
  • 20,029 posts
  • MVP
Start, (Settings,) Control Panel, Network Connections. Find: Local Area Connection and right click and select Properties. Find Internet Protocol (TCP/IP) and click on it then hit Properties. Click on Use the Following IP address:

Fill in the blanks as follows:

IP address space: 192.16.2.111
Subnet Mask: 255.255.255.0
Default gateway: 192.168.2.1

Click on Use the following DNS Server addresses

Fill in the blanks as follows:

Preferred DNS Server: 192.168.2.1
Secondary DNS Server: 8.8.8.8

Then hit Advanced and select the WINS tab Click on Disable NetBIOS over TCP/IP
OK
OK
Close.

Connect up the Ethernet cable to your PC. (If it was already connected then disconnect it and connect it up again.

Start, Run, cmd, OK

ipconfig

(Should show 192.168.2.111, 255.255.255.0 and 192.168.2.1. Does it?)

ping 192.168.2.1

(Do you get a response?)

If so then try your browser and see if it works now.

Ron
  • 0

#15
KDHoost

KDHoost

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I cannot connect via ethernet; the router is in the apartment above me and I have no access.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP