Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

(Another) Realtek NIC can't find plugged in cable

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts

I'm new here, I just signed in a few minutes ago. I hope you can help me, and I hope I can bring some light to some of the problems over here :-)
I've seen several posts similar to this in the forum, but most of them had this "Error code 10" in Windows, and I don't.

I have been having some problems with my network card for a couple months and I can't solve them.

Short description:
- the network card does not recognize that the ethernet cable is plugged in any more and therefore I cannot connect to the network.
- the green and yellow lights do not show up anymore with the cable plugged in.
- Realtek's Windows diagnostic program shows no hardware errors.
- Windows recognizes the network interface and shows no errors.

A bit longer description:
I have an HP laptop with Windows 7 64bit which uses a RTL8101E Integrated Fast Ethernet Controller and it was working fine with Windows 7 and the Windows driver, but then it stopped working with no apparently reason.

I've tried to uninstall the NIC from the Device Manager in windows, remove driver, reinstall driver and nothing works. I tried to change the driver for this one:

"Win7 and WinServer 2008 R2 Driver", version 7.046 from 2011/8/3.
"Win7 and WinServer 2008 R2 Auto Installation Program (SID:1462014)", version 7.046 from 2011/8/3.

available at the Realtek website for the following cards:


But also didn't work.

I have also downloaded from the Realtek website the "Windows Diagnostic Program", version from 2011/6/29. This program shows me there's no hardware error. Actually, when the tests run, I can see the green light blink, and the yellow sometimes (by EEPROM test or MAC Loopback test). The transfer/receive test I could not do, since the network card does not recognize the plugged-in cable and I don't have 2 windows computers to test this.

Also the Windows Device Manager shows no problems with the network card, and shows the device is recognized, and works perfectly.
Do you have any idea what the problem could be? Do you have any hints to solve this? In the meantime I can connect via Wireless interface, but I would like to go back to the ethernet connection.

Ah, and of course the cable, the modem and router work: I checked them all with a Linux computer.

Thanks for the help! and sorry for such a long post!

  • 0





  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
You need the driver from the HP site, not from the Realtek site.
Try this one

That said, the symptoms suggest a fault with the connection, as you APPEAR to have eliminated the cable.
Although if there is by chance a fault on the cable, moving it to try on another computer could easily remake the faulty connection.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP