Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Easy question - How to access new ftp server?


  • Please log in to reply

#1
UV_Power

UV_Power

    Member

  • Member
  • PipPipPip
  • 391 posts
Hey everyone,

This should be a nice softball question, so here goes. I am trying to create a web/ftp server for the first time. I am using Ubuntu 10.04 Server Edition with Apache2. I got the web part set up (i.e. I can type in http://my.server.name in any web browser and it brings up a page that says "It works!"), but I am having trouble figuring out how to access the ftp part.

I have installed vsftpd and I am able to edit the vsftpd.conf file to configure the settings for ftp access. The only thing is that I cannot figure out how to actually access the ftp server remotely (as a user, for example) to upload and download files. I have verified that the vsftpd service is running and I have verified that the router and firewall have the proper ports open (20 and 21).

Now, when trying to access the server itself, using ftp://my.server.name via Firefox or Filezilla, I always get a connection time out. Presumably, this is happening because I have not set up any folders on the ftp server itself to point to when users are accessing them (I think... :) ).

So here are my questions: What is the default FTP URL that users should be using? Where is this specified (I couldn't find it in vsftpd.conf)? What other factors could be causing the connection time out? I have tried searching for the answer to this, but I only get resources which tell me how to edit the vsftpd.conf file, which only helps with user access settings and doesn't help me with what URL I need to give to users.

Sorry if this is a terribly obvious answer, but I am stuck.

Thanks in advance!
  • 0

Advertisements


#2
Cold Titanium

Cold Titanium

    Trusted Helper

  • Malware Removal
  • 1,735 posts
It's been quite a while since I've looked at this, but you may want to take a look at hosts.allow and hosts.deny

Also LINK
  • 0

#3
TravisB

TravisB

    Member

  • Member
  • PipPip
  • 21 posts
Can you try to (locally) ftp? When logged in through the machine [whether you have a KVM attached to it, or through ssh], try to use the 'ftp' command (I believe it is installed with your distribution, if not it should be easy enough to get).

Although the daemon is running, it could have something hinky going on in the background. vsftpd has done that to me on more than one occasion with its config file :)


Along with that, can you post
netstat -nlp
?

My suspicions, however, would be from this command:
iptables -L

[note: run as root. This will list your firewall rules]

Depends on your local rules, if they're set to accept all and deny some, or the opposite, so we can't just grep for 21 :P



[edit] I feel so terrible, I didn't notice how old this was. I just saw it was pretty close to the top of the first page.

Sorry about that :/

Edited by TravisB, 27 December 2011 - 07:45 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP