Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Stereo Mix recording options; Vista vs. Win7


  • Please log in to reply

#1
Brennan C.

Brennan C.

    Member

  • Member
  • PipPip
  • 78 posts
Hey, everybody!

Hopefully this is a quick question. My system is set up to dual-boot between Windows Vista Home Premium and Windows 7 Professional. When I'm in Vista I'm able to use Audacity to record "Stereo Mix," that is, I can record exactly what comes out of my computer's speakers. When I'm in Windows 7, however, I'm not able to select that option in Audacity; furthermore, "Stereo Mix" isn't an option when disabled and disconnected devices are showing in my system's sound settings. Does anybody have any idea why this is, and if there's a fix or a workaround for it?

Here are my system specs:

Posted Image

I'm posting about this in this forum because the research I've done on this topic leads me to believe that my problem is hardware-related. Feel free to refer me elsewhere if that's not the case.

Thank you all for your help! :-D

- Brennan
  • 0

Advertisements


#2
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
If you have the latest Audicity beta version you need to go to edit / preferences/ then select the appropriate playback device.


Hope that helps
  • 0

#3
Brennan C.

Brennan C.

    Member

  • Topic Starter
  • Member
  • PipPip
  • 78 posts

If you have the latest Audicity beta version you need to go to edit / preferences/ then select the appropriate playback device.


Hope that helps


I am using the latest Audacity Beta version, but there's no option under that menu for Stereo Mix. Also, my problem isn't with playback.
  • 0

#4
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
No it is the playback as in what soundcard device you need to specify, it is probably right now under the Microsoft Wave mixer (or similar) and not your Realteck Sound Card so when sound is played through your system Audacity is no reading the stereo mix from the Microsoft wave device.

Usualy Audacity reads your soundcard automatically but in windows 7 for saome reason it does not so you have to go and change it manually in the Audacity preferences.

Edited by Alzeimer, 23 October 2011 - 04:26 PM.

  • 0

#5
Brennan C.

Brennan C.

    Member

  • Topic Starter
  • Member
  • PipPip
  • 78 posts
OK, so I tried every combination of options in that menu:

When "Windows DirectSound" is selected as the Interface Host, I'm given the following options:

Playback-
Device:
- Primary Sound Driver
- Speakers (2- High Definition Audio Device)
- Digital Audio (S/PDIF) (2- High Definition Audio Device)

Recording-
Device:
- Primary Sound Capture Driver
- Microphone (2- High Definition Audio Device)
- Digital Audio (S/PDIF) (2- High Definition Audio Device)

And when "MME" is selected as the Interface Host, I'm given the following options:

Playback-
Device:
- Digital Audio (S/PDIF) (2- High
- Speakers (2- High Definition Au
- Microsoft Sound Mapper - Output

Recording-
Device:
- Digital Audio (S/PDIF) (2- High
- Microphone (2- High Definition Au
- Microsoft Sound Mapper - Input

No combination of those allowed me to record the audio playing on my computer (I left music playing while I did the tests). Is there a combination of settings in there that should work?
  • 0

#6
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts

Playback-
Device:
- Speakers (2- High Definition Audio Device)

Recording-
Device:
- Microphone (2- High Definition Audio Device)


This is the comnination I would use if your sound card setting is on Realtek High Definition Audio

If that does not help the only other option I woukd suggest is to uninstall Audacity and reinstall it under Compatibility Mode to see if this will help.

Edited by Alzeimer, 23 October 2011 - 06:26 PM.

  • 0

#7
Brennan C.

Brennan C.

    Member

  • Topic Starter
  • Member
  • PipPip
  • 78 posts
Setting my recording device to my microphone doesn't solve my problem; remember, my problem isn't that I can't record from my microphone, it's that I can't record streaming audio playing on my system. I'm able to do this when I'm running Windows Vista, but the option simply isn't there in Windows 7.

When I'm running Vista, when the Audacity settings are good to record the Stereo Mix, the window looks like this:
Posted Image

When I'm running Windows 7, however, "Stereo Mix" isn't an option under the recording devices menu. This is what leads me to believe that I have a hardware/driver problem, which is why I posted about it in this forum.
  • 0

#8
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
I do not know if you read this on Audacity website about Windows 7:

Select inputs in Devices Preferences or Device Toolbar: In Windows XP and earlier in Audacity 1.3.12 and earlier, recording inputs such as "microphone" or "stereo mix" could be selected in the Audacity Mixer Toolbar. However the newer audio API in both Windows Vista and 7 requires that inputs be selected in Audacity at Edit > Preferences: Devices or Device Toolbar. From 1.3.13 Beta onwards, input selection has been moved from Mixer Toolbar to Devices Preferences and Device Toolbar for all operating systems.

If you wanna read all the information this is the link
http://wiki.audacity...ki/Windows_7_OS
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP