Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't install F.Lux


  • Please log in to reply

#1
muhib1996

muhib1996

    Member

  • Member
  • PipPip
  • 91 posts
I use Ubuntu 10.04 LTS version. I have downloaded the .deb package of F.lux (for lucid) and installed it. The applet shows, but the color temparature doesn't change. Even the Preview buttons doesn't work, not even the Pause or Unpause buttons. What to do?
Someone says maybe it's for Graphics Card. I have no G drivers installed in Ubuntu, though my Ubuntu Graphics works well (It's NVIDIA, I face some errors while installing G card).
It should be mentioned that F.lux works nicely in my Windows OS (win 7), but it can't be run in Ubuntu. Any suggestions? Please help....
  • 0

Advertisements


#2
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
1.

I have no G drivers installed in Ubuntu, though my Ubuntu Graphics works well


You do of course have a graphics driver installed -
If you mean - you do not have the proprietary graphics driver - then go

System - Administration - Hardware drivers and if Ubuntu recognises that they are available for your card, another window will open.
Before you click 0n Activate - note if the driver has been tested by Ubuntu - otherwise if you activate you may have problems.
Some graphic card manufacturers for certain chips have made available drivers for Linux based systems.

2. Until you posted I did not know F.lux for Linux - in fact I had never heard of it.I have now had a look at it. In fact I have installed it.
It worked on a terminal window with the usual sudo apt-get etc as per this link here
http://stereopsis.com/flux/linux.html

I do not like it, the forums are full of reports from people having problems and in all honesty, unless the user had a particular optical related reason for needing such a utility - I consider it a gimmick.
I have un-installed it, using synaptics package manager and then Computer janitor.
  • 0

#3
muhib1996

muhib1996

    Member

  • Topic Starter
  • Member
  • PipPip
  • 91 posts
Actually, I installed a G driver as you said, I know how to install it. Then I tried to enable desktop effects, the effects were nice. But when I restarted, it returned to it's previous state. So, I uninstalled the driver.
I came to know that F.Lux may not work for G driver. Yesterday, I updated my Ubuntu (some updates were available). Then I installed the driver (there actually shows 2 driver, one is marked 'recommended', I tried both of them in my past) and restarted. Then I got a message something like this- "Ubuntu is running under low graphics card....ERROR....You may need to update your configuration to solve this issue."
So I think, the latest Ubuntu is not supporting the driver. Yet, I will try again and report back to you. The driver is tested by Ubuntu Developers. And I also have eye-sight problems (horrible!!!), so F.Lux is one kind of MUST for me. It works really nice for my eyes, trust me.
  • 0

#4
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
Hope you can get it working.
  • 0

#5
muhib1996

muhib1996

    Member

  • Topic Starter
  • Member
  • PipPip
  • 91 posts
Macobaster, please tell me, When you tried F.Lux in your Ubuntu system, did it work nicely or you faced the same problem as me?
  • 0

#6
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
It worked.
  • 0

#7
muhib1996

muhib1996

    Member

  • Topic Starter
  • Member
  • PipPip
  • 91 posts
Hmm... it didn't work for me and I didn't try to install Graphics Driver again. But I have a nice solution, for user information:

You can use "RedshiftGUI", a program inspired by F.Lux. I am now using it and it works very well. I am very happy. So the matter is solved, thanks.
  • 0

#8
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
Good, glad you got it working.
Saw that it was on the link I sent you

Don't forget about Redshift (http://jonls.dk/redshift/) which provides similar functionality for Linux.





It is a matter of little importance - however

Macobaster


please try it with another M, another T and another A
  • 0

#9
muhib1996

muhib1996

    Member

  • Topic Starter
  • Member
  • PipPip
  • 91 posts

please try it with another M, another T and another A

Um...What do you mean by this?:confused:
  • 0

#10
greenwarrior

greenwarrior

    Member

  • Member
  • PipPip
  • 57 posts

please try it with another M, another T and another A

Um...What do you mean by this?:confused:

Actually he wants to tell you that you missed a M,T and A when writing his name.
His name is Macboatmaster not macobaster. Hope you understood it now. :thumbsup:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP