Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

HD 5850 clock speed varies at random


  • Please log in to reply

#1
averysadman

averysadman

    Member

  • Member
  • PipPipPip
  • 176 posts
I have stumbled into the mire that is messing with the clock speed on an ATI card.

I have a HD 5850, and it had been flickering and messing about on the desktop while idle, and getting artifacts while trying to play videos. This only happened some of the time, and I recently discovered that it had been spontaneously and randomly underclocking itself to 157MHz, instead of the usual 400MHz for idle.
I've managed to keep it at 400MHz idle which is the default for the card, but it doesn't set the clock higher for fullscreen videos and the like, which it should as it causes performance problems, and I have no idea why.
When it needs more power, like in a game, it's supposed to raise the clock to 725MHz, which it now only does sometimes, there doesn't seem to be any rhyme or reason to it. I never changed any settings, never tried to overclock or anything like that, it did all of this seemingly by itself.

The HD 5850 has a mind of it's own and does not cooperate.

I did some tests, as I use a lot of monitoring software while I'm running games.
I tested multiple high-resource games, but I'll use Crysis 2 for this example.

I tried running the game 6 times, and 4 of those times the clock speed stayed at 400MHz causing a 20fps loss in the game, and the other 2 times it did what it was supposed to do, and raised the clock speed to 725HMz, playing at normal framerates.
I can't find any reason behind it, it's random.

Is there a way for me to bypass CCC and lock it at a certain clock/memory speed?
  • 0

Advertisements


#2
averysadman

averysadman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 176 posts
Update:
I have tried completely disabling CCC, including Overdrive and EYEfinity, it doesn't seem to change a thing.
I've also discovered that it will vary the clock speed if I ALT+TAB out of a game, I just tabbed out of a game, and when i tabbed in again the clock speed had lowered, I tabbed out, and back in again, and it went back to normal.
  • 0

#3
averysadman

averysadman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 176 posts
I have solved the problem.
I manually edited the XML file in Appdata>Local>ATI>Profiles to show the values I wanted. If this profile is saved, it can be set to override the default CCC setting if selected from the system tray.
Everything is now performing properly.
  • 0

#4
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 19,993 posts
Hi averysadman
Glad to hear you resolved the issue and thanks for sharing the solution so that it may help others :thumbsup:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP