Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

XP Home reinstall/repair no keyboard when (repair/reinstall option) No


  • Please log in to reply

#1
1eagle

1eagle

    Member

  • Member
  • PipPip
  • 10 posts
Hi all Im new to the group but need help. My Dell Dimension 3000 all factory booted with a invalid Boot.ini and finally says " Windows could not start because the following file is missing or corrupt": (Windows root)\system32\hal.dll.Please re-install a copy of the above file.

I need to get this computer up and running because of the files. Don't care about all the programs, i have all that. I need the data.

Any help would be helpful...

Thanks

Edited by 1eagle, 05 February 2012 - 02:31 PM.

  • 0

Advertisements


#2
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,019 posts
:welcome: 1eagle
Please clarify what you mean you have no keyboard! (Read your topic title)
  • 0

#3
1eagle

1eagle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
I boot to the cd reinstall, keyboard works, get through the boot sequence and come to reinstall=enter repair=R exit=f3 I have no keyboard..... no response from the keyboard..... no mouse..... nnothing
  • 0

#4
1eagle

1eagle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
I am running the bios utility and selected "cannot boot to os" not complete yet ann passed so far
  • 0

#5
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,019 posts
Thanks :thumbsup:
What type of keyboard are you using USB or the PS2 (wired) type?
  • 0

#6
1eagle

1eagle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
ps2
  • 0

#7
1eagle

1eagle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
can I ask if the keyboard works to select the cd boot option and my problem is a hal.dll file missing, why would my keboard not work with a OEM cd ??
  • 0

#8
1eagle

1eagle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
gotta git off line. this is my sons computer and he needs to finish a paper.... my email is rtkaba@yahoo.com please give me whay you can on the blog and with email... thank you very much.....
  • 0

#9
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,019 posts

ps2

Does it have a purple plug on the end? I ask as some are the USB type used with a PS2 adapter as in the .jpeg!

can I ask if the keyboard works to select the cd boot option and my problem is a hal.dll file missing, why would my keboard not work with a OEM cd ??

The keyboard is initially working within the BIOS and then the OS is meant to take over but as it is damaged it is not happening.

Sorry assistance is only offered on the forums, this is in the best interests of us all and so that others may learn.
  • 0

#10
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
1eagle

You are being assisted here now my my colleague phillpower2.

You started this topic at 8.14pm today.

However you also posted here in this topic at 8.47pm
http://www.geekstogo...__fromsearch__1

I was typing a reply to that post, when I realised that, as you had only joined GeekstoGo today and your record showed 7 posts, you must have another thread running.

I then of course found this one.

For your future information PLEASE do NOT post the same problem in TWO places. It could have wasted the time of people assisting you.

Thank you.
  • 0

Advertisements


#11
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,019 posts
Thanks Macboatmaster :thumbsup:
I will be going offline shortly and would appreciate your assistance if the OP replies.
  • 0

#12
1eagle

1eagle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
sorry, i was frustrated knowing i needed data on this computer for monday, today. I appoligize for being rude. I still need help with this problem. Thank you to whoever posts
  • 0

#13
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
The best advice I can give you now, as I am just about to sgin off it is 0230 here in UK

Use this to secure your data
http://www.geekstogo...over-your-data/


Your keyboard and mouse will very likely work on this.


On the link do download Puppy it no longer goes to 520 edition, as there is a new edition.
Here is the link to 520 - everything else on the guide is the same.
http://ftp.nluug.nl/...inux/puppy-5.2/


Lupo 520 Iso is the one you want - size 127M
  • 0

#14
1eagle

1eagle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Thank you very much but decided to do a clean install.... in the process now. thank you all for the help.
  • 0

#15
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
Thank you for posting the response.

I thought you needed to secure your data

I need the data.


However , Good luck with it.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP