Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works


  • Please log in to reply



    New Member

  • Member
  • Pip
  • 6 posts
Does anyone else have this problem? We downloaded Service Pack 2 and now we are unable to use iTunes. We removed SP2 and viola! iTunes is up and running! We are experiencing more browser problems than normal since removing SP2, even though we are using Netscape instead of IE. When we had our computer in the shop for a hardware problem, we asked the guy about our problem with iTunes and he said he'd never heard of it & that we shouldn't have any problems at all. Microsoft's website doesn't deal with this issue either. Is it just us? Thanks!
  • 0




    Retired Staff

  • Retired Staff
  • 11,365 posts
this was known to occur sometimes...usually, uninstalling sp2, then itunes, then reinstalling sp2 and installing itunes on top of that works
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP