Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Home network problem


  • This topic is locked This topic is locked

#1
JButler

JButler

    New Member

  • Member
  • Pip
  • 6 posts
I'm new to this so please bear with me.

I've just purchased a laptop and have been attempting to hook it up to my desktop via a simple home network. The laptop and desktop are connected together by a firewire cable, and the desktop hooks up to the net by cable modem.

Now here's the problem - while the network itself seems to work fine and I can move fies between machines with no problems, the laptop just cannot see the internet. I see that several others have had similar problems recently but none of the resulting threads seem to have any advive specific to my situation.

Here are what I hope are the relevant points:
1. Both machines are running XP Home
2. Internet Connection Sharing is enabled on the desktop.
2. The desktop's "Internet connections" dialog box shows two connections:
(a) Internet connection via cablemodem: connected, shared. IP address is obtained automatically
(b) Firewire connection to laptop: connected. IP address is 192.168.0.1
3. The laptop's "internet connections" dialog box shows:
(a) Internet Gateway, internet connection via cablemodem on desktop, connected.
(b) LAN: (i)local area network (standard ethernet connector) disabled
(ii) Wireless network connection, not connected
(iii) firewire connection to desktop, connected. IP address obtained automatically.
4. Both machines' internet firewalls are off though they are both running Zone Alarm.

As I said, the two machines talk to each other and the desktop connects to the net but the laptop can't see it at all. I've probably missed something obvious but I'm stumped. Any advice gratefully received. Please bear in mind that I don't have a clue what "pinging" is nor what "cmd" commands are, so any diagnostics you suggest I run involving these approaches will need explaining in detail.

Thanks in anticipation.
  • 0

Advertisements


#2
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
Make sure that the default gateway on the Laptop is the IP address of the Desktop.

Also, I see that you are specifying one of the IP addresses as 192.168.0.1, make sure that the one set to "Obtain address automatically" is acquiring an address that is similar. (192.168.0.?). Also, ZoneAlarm IS a firewall. Disable it until the connection is working. Then we can configure if it causes problems when on.

Greazy Mcgeezy
  • 0

#3
JButler

JButler

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Um... I'm sorry, Greazy, thanks for your reply but I don't know what a default gateway is.

Also, I'm connected to NTL's cable network and IP addresses are assigned automatically. I don't know what my desktop's IP address is at any given time, or how to find out. Neither do I know how to find out what my laptop's IP address is, or even whether it's been assigned one. (Maybe this IP address assignment is the root of the problem as I simply don't know what I'm doing).

Sorry, I did say I was new to this. I hope everyone out there can be patient with me. I can tell you that I've disabled Zone Alarm on the laptop and that it's not made any difference.

JohnB.
  • 0

#4
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
I'll be helping you until either problem is resolved, or you get tired of trying. So no worries about patience.

Um... I'm sorry, Greazy, thanks for your reply but I don't know what a default gateway is.


Ok, in order for a device to communicate with another device using the IP protocol, it must have two things: an IP Address, and a Subnet Mask. In order for that same machine to connect to another network (ex.- the internet), it must also have a default gateway. The default gateway is the ip address that you connect to to get out of your own network.

Also, I'm connected to NTL's cable network and IP addresses are assigned automatically.


Right, the IP address is assigned to the interface on your machine that is connected to it. That is the interface that needs to have ICS enabled.

I don't know what my desktop's IP address is at any given time, or how to find out. Neither do I know how to find out what my laptop's IP address is, or even whether it's been assigned one.


The easiest way to find your IP address(s):
You will need to do this on each machine
Click Start>Run, type; cmd
At the command prompt, type; ipconfig,
This should show you the simplified information for all the adapters that are connected on that machine. Look for the connection that refers to the 1394 connection(firewire), you should see information on the following:
IP Address, Subnet Mask, and Default Gateway.

The default gateway on the laptop, should be the same as the ip address of the desktop. More than likely, the IP on the desktop to the firewire connection, is something like; 192.168.1.100, which means the ip of the laptop should be 192.168.1.101, subnetmask=255.255.255.0 (both machines), and default gw on laptop = 192.168.1.100. DNS on laptop would also be 192.168.1.100. Try these settings and let me know what happens, any questions, you know where to ask.

Greazy Mcgeezy
  • 0

#5
JButler

JButler

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Thanks Greazy, those are the clearest instructions I've had so far and the fix looked promising, unfortunately it's still not working.

I've been researching the ipconfig command with Google and it looks like a useful diagnostic - with this in mind I decided to run "ipconfig /all" on both machines and let you see the results. Hopefully you might spot something obvious.

On the desktop, I get:
Windows IP configuration
Host name..........Hal
Primary dns suffix
Node type.........unknown
IP routing enabled.....yes
WINS proxy enabled......no

Ethernet adapter internet connection via cablemodem
Connection specific DNS suffix
Description:......Netgear FA311 fast ethernet adapter
Physical address ...(censored)
Dhcp enabled.......yes
Autoconfiguration enabled......yes
IP address (censored)
Subnet mask...255.255.255.0
Default gateway....(censored).85.254
DHCP server...(censored).64.23
DNS servers....(censored).4.100
(censored).8.100
NEbios over TCP/IP...disabled
Lease obtained...(snipped)
Lease expires...(snipped)

Other adapter firewire connection to laptop
Connection specific DNS suffix
Description:......1394 net adapter
Physical address ...(censored)
Dhcp enabled......no
IP address....192.168.0.1
Subnet mask...255.255.255.0
Default gateway....


Meanwhile, on the laptop:

Windows IP configuration
Host name.........Acer (lots of alpanumerics)
Primary dns suffix
Node type.........unknown
IP routing enabled.....no
WINS proxy enabled......no

Ethernet adapter wireless network connection:
Media state.....disconnected
Description .....Acer IPN2220 wireless LAN card
Physical address...(snipped)

Other adapter firewire connection to desktop
Connection specific DNS suffix
Description:......1394 net adapter
Physical address ...(censored)
Dhcp enabled......no
IP address....192.168.0.2
Subnet mask...255.255.255.0
Default gateway....192.168.0.1
DNS servers.....192.168.0.1

Hope that tells you something - I'm completely baffled.
John B.
  • 0

#6
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
From the look of it, everything "should" be working. But let's try this since it's not. Since it is showing that the Laptop IS connected to internet using the Internet Gateway, (your first post), on the Laptop, try bringing back up the command prompt, cmd from Run, try to ping an outside source:

ping google.com

If that DOES NOT WORK, try this,

ping 216.239.37.99

If the second of the two works, then you have a DNS issue. If neither of them work, then you aren't even speaking to the outside world and we have a problem at the desktop. Also, make sure that neither of the machines have a firewall, I know you have disabled, but double-check just to make sure, more than likely, it would be a firewall on the desktop that may not allow you out, (if it's firewall related). Keep me updated!

Greazy Mcgeezy
  • 0

#7
JButler

JButler

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
We've hit it, Greazy - it's ZoneAlarm on the desktop that's causing the problem, which I'd not previously considered and not thought to disable. Initially both "ping" commands failed, the first told me that it couldn't find the host, the second time (with the raw url) timed out. I then killed Zone Alarm on the desktop and the whole system burst into life.

Amazing that, all this time, it was a peripheral issue and nothing to do with the network settings. However, having said that, the network connection wizards were pretty useless and had not even touched the IP settings on the laptop.

Thanks for your help and patience, without which I'd still be tearing my hair out. There are so many traps to ensnare the unwary and without discussion boards like this most of us wouldn't have a clue where to find the answers.

Now I need to go through zone alarm's documentation and find out what to set (if anybody reading this has a similar experience please speak out, it could save another couple of days of digging and trial-and-error frustration). After that, I will have the interesting experience of getting the laptop to communicate through a wieless network for the first time. But that's another story.

John B.
  • 0

#8
JButler

JButler

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
An initial finding that may be helpful to others - Zone Alarm does not support internet connection sharing, so running zone alarm on a gateway machine will automatically lock out other machines on the network from the web. It's necessary to shell out some money and upgrade to Zone Alarm Pro.

John B.
  • 0

#9
JButler

JButler

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
A further observation after trying the fix. Even after upgrading to Zone Alarm Pro and configuring it as recommended for internet connection sharing, the problem still persists and the laptop will still not connect to the net. A quick look at Zone Labs's own user forums reveals that (a) this is a common problem that many users are complaining about, and (b) there doesn't seem to be a solution. What a great product.

Oh well, I've proved that the laptop will talk to the net, which was the primary purpose of the exercise, and I've spent the rest of the evening downloading a few updates and patches to the installed software. I figure it won't need hooking up to the net at home more than once every few weeks in order to keep it updated. Presumably I can live with XP's own firewall rather than Zone Alarm whenever I need to hook it up.

But looking ahead to a possible situation in which I might want to use it more regularly, might it be worth investing in a simple router instead of hooking the two PCs directly together? Would this bypass the need for internet connection sharing and the can of worms it seems to have opened up, or does one machine still have to operate as the internet gateway?

John B.
  • 0

#10
Rico750

Rico750

    Member

  • Member
  • PipPip
  • 93 posts
grrr... zonealarm always causing trouble...
  • 0

#11
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
I'm really glad that we got your situation straightened out John. For your question, yes, it would be better to get a router if you plan on doing this frequently. Make sure if you do, get one that has a WAN port, as well as the 4 switch ports. You would plug modem into WAN port, then connect the computers to the other 4 ports. Set all to Obtain automatically, and just make sure DHCP on the router is set to enabled. Again, I'm glad you have gotten straightened out.

Greazy Mcgeezy
  • 0

#12
Qas

Qas

    New Member

  • Member
  • Pip
  • 1 posts
Hi,

I have using Zone Alarm (Free) for some time and it has been working fine. I have a small home network of 5 PCs and they all can connect to the internet and there is no problem accessing web pages at all.

My setting is as follows:

1. I have added a trusted zone by putting the ip range from 192.168.0.0 to 192.168.0.255 (this is done by clciking 'Firewall', and Zone tab then click 'add' button. This would be your trusted zone.

2. The in 'Firewall>main' option set 'Main Zone Security' to 'Medium' and 'Trusted Zone Security' to 'Low'.

3. Obviously, the internet connection on the main PC is shared.

Every thing is working fine untill now when i installed the latest update 55_094_000.

So if anyone knows how to fix it, please let me know.

Cheers
  • 0

#13
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
Hello Qas Welcome to Geeks to Go. Please start your own topic in this networking forum. When multiple users post their situation in the same thread it gets confusing. Thanks.

-=jonnyrotten=- :tazz:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP