Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Bad battery, mouses, chargers?


  • Please log in to reply

#16
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,024 posts
Hello Psu22UL

Should we just close this up and I'll send PM if/when I decide to fix this up?

GTG never close topics without just cause or by a specific request of the OP, reply when you are ready and after an update we can move on.
  • 0

Advertisements


#17
Psu22UL

Psu22UL

    Member

  • Topic Starter
  • Member
  • PipPip
  • 90 posts
Ah, ok. I'll get back when I get it fixed up. Thanks for all the help!
  • 0

#18
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,024 posts
You are welcome - good luck meanwhile :thumbsup:
  • 1

#19
Psu22UL

Psu22UL

    Member

  • Topic Starter
  • Member
  • PipPip
  • 90 posts
I got one of the mice back, and everything seems good. Except for the fact that it isn't working. It's detected by another computer, the computer says it's working properly. I checked that all it's updates were up to date (they were). It lights up like it's on. Yet it doesn't work..Any ideas on why this would be?
  • 0

#20
Psu22UL

Psu22UL

    Member

  • Topic Starter
  • Member
  • PipPip
  • 90 posts

I got one of the mice back, and everything seems good. Except for the fact that it isn't working. It's detected by another computer, the computer says it's working properly. I checked that all it's updates were up to date (they were). It lights up like it's on. Yet it doesn't work..Any ideas on why this would be?


Anyone?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP