Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Twitter/google images/Internet explorer problem


  • Please log in to reply

#1
Bluestaar

Bluestaar

    New Member

  • Member
  • Pip
  • 1 posts
I have windows 7 and a Lenovo laptop .. Haven't even had it for a month yet.. Probably cause of some of my downloads and settings but for some reason all sites work fine but when I go to twitter.com the background image doesn't load

It just shows a black background and never loads up..

Also when I go to google images , it just shows grey boxes and no images.

I clear my cache and cookies and it shows google images again but a day later and it's back doing the same thing

And I run Firefox

Another problem is the my Internet explorer loads but freezes after I type in the first site I want to visit
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP