Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

My graphics card won't get recognised, help!


  • Please log in to reply

#1
TheRandomGuy7

TheRandomGuy7

    Member

  • Member
  • PipPip
  • 11 posts
Hi,
I just finished building my first ever PC today. Everything works fine, I have installed Windows 7, antivirus and everything that is needed. When I say everything works, I mean except just one extremely annoying problem. My Radeon 7850 just will not be recognised by windows/the motherboard/ whatever is meant to detect it. In the manual for the GPU it says I need to disable the onboard graphics, which I have Intel HD4000, but how do I do this? There doesn't seem to be an option to do so in the BIOS. I tried disabling something like "internal graphics" but that caused massive errors and multiple speaker beeps and no monitor input, requiring a CMOS reset. So how on earth do I disable the integrated graphics, and/or get it to recognise my card, without breaking anything?

Here are my full specs:

Gigabyte Z77-D3H Motherboard

Intel i5-3570k Processor

8GB GSkill Ripjaws RAM

Sapphire Radeon 7850 2GB Graphics Card

XFX Pro 650Watts Power Supply

Seagate Barracuda 1TB Hard Drive

Thanks a lot for any answers, I really need help right now :S
  • 0

Advertisements


#2
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
In your BIOS under PERIPHERALS go to the choice of INIT DISPLAY FIRST and either put on AUTO to let the bios choose or if that does not work try to put it on PEG for pci-express to be rhe main display.

By telling the bios to AUTOmatically choose or to tell it to go directly to your pci-express PEG the BIOS will not initialize your internal graphic.

If on AUTO by default your motherboard will see the pci-express as your primary display if you have a pci-express card connected to it if none are present it will start the integrated graphic so make sure your pci-express card (Radeon 7850) is properly seated and powered to make the BIOS recognize that there is a card plug.

If you put it on PEG then you can disable your internal graphic if you leave it on AUTO do not disable it.


Hope that helps

Edited by Alzeimer, 07 December 2012 - 04:15 AM.

  • 0

#3
TheRandomGuy7

TheRandomGuy7

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Ok, are you sure you mean PEG and not PCI? I tried changing the Init to PCI, but to no avail. So if I tried putting it on this PEG instead, it may work?
  • 0

#4
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
PCI is for a a regular old pci graphic card

PEG is for Pci Express Graphic, if choosen the bios will go there first to get your display.

Auto is the default way meaning that the bios detects where you have graphic cards and on which one your screen is connected to
  • 0

#5
TheRandomGuy7

TheRandomGuy7

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Ok thanks, turned out my graphics card doesn't seem to work in the first slot (PCX16) so I tried it in the X4 and it works! :D Only problem is, and an extremely annoying one, the card in that slot blocks access to all but one SATA ports! So I can only have my single HDD installed at any one time, that means no disk drive.
  • 0

#6
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
On what option did you put the BIOS on PEG or on AUTO

if on PEG disable the integrated graphic

if on AUTO put the integrated graphic on the default (auto)

If after that your motherboard does not detect your card in the 16x slot but only in the 4x then maybe your board has a default that if still under guarantee I would have checked.
  • 0

#7
TheRandomGuy7

TheRandomGuy7

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Yeah it turns out it is not just me, but it is a whole compatibility issue with that card in that particular slot for some reason. The board and card both work fine, so no action needs to be taken.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP