Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Bios Change then no bios post

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hi I changed a setting in the bios to load optimum defaults and immediately after the change it's refused to power on self test.Fans spin but no beeps.Tried all cables disconnected except main + 4pin power.Cleared cmos replaced battery.Graphics card - OK.Could the change in the bios corrupt itself?Btw power to all components confirmed no blown caps .Memory good-tried taking cmos battery out all to no avail.Any way to get back to bios? maybe replacing the bios chip?Thanks john
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP