Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

BF3 Voice Chat-Problems

  • Please log in to reply




  • Member
  • PipPip
  • 15 posts
Hello Guys/Girls,

I've been playing BF3 for awhile and using decided to get myself and get a 7.1 surround sound Razer Megalodon Headset. However, when I try to use the headset I am hearing wind noises on the other persons end via feedback to my headset. It is not all the time but it does get annoying after awhile. I turned down the main volume settings on my new headset to 30 to see if that would do the trick but still getting problems last night. I am also getting laggy sound (i.e. My naaaa_______meeeee is J_____oooo^E-kinda audio metric noise). Also, every time I speak I am hearing my own voice back into my headset.

1. Wind Sound on the receiving persons end.
2. Laggy Sound-Only happened in one game.
3. Feedback of my own voice into my headset.

Attempted Solutions:
1. Turned down the device itself to have an overall volume of 30.
2. I have no idea how to solve that one.
3. Audio Loop is Disable in the Battlefield 3 Voice Feature.

Just to give you some background on my machine

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120830-0333)
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: h8-1080t
BIOS: BIOS Date: 05/27/11 10:01:40 Ver: 6.14
Processor: Intel® Core™ i7 CPU 970 @ 3.20GHz (12 CPUs), ~3.2GHz
Memory: 9216MB RAM
Available OS Memory: 9208MB RAM
Page File: 2207MB used, 16204MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 64bit Unicode

Any help on this matter would be great, I am some-what lost on this one.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP