Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

laptop aspire 7560 problem

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 3 posts
I am not really sure how this site works but a friend suggested I give it a try. I have a laptop Aspire 7560. One day, it kept losing the webpage I was on, stating it had to "recover". I did a force shut down and rebooted. After that it said I had nothing on the drive. I sent the laptop back, under warranty. They installed a new drive. I started it up, connect to internet, no matter what site I try to get on...it opens the browser window slow as heck, then says it lost the page. I try to open a document file from Office, it takes forever for it to open it up. Then it freezes up, I try to close/exit out of whatever I was trying to open, and it doesn't do crap but sit there...frozen. I try to open task manager...it doesn't. I had to do a force shut down again...restart...reconnect to internet...takes forever to open up msn or any browser window. WHY????? I am about ready to throw it in the yard. Help!!!!!
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP