Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Dell XPS L511Z Electrical Short ("pop" sound) and dead Laptop

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hello All,

After an exhausting search on many forums, I'm still left without the definitive answer im looking for, so hopefully we have an expert out there for my issue!

First off, I have a XPS L511Z, a little over a year old. So, last night, while the laptop was on, I tried plugging in the adapter to the laptop and I heard a "pop" noise, followed by a dead laptop with a burning smell. I've already opened up the laptop to replace a HD failure (for my 4th dell computer, I don't know why I'm having so much trouble with my latest purchase :( ), so I opened it up again to look around for any obvious shorts. Here are a few interesting things I found:

1) The laptop is dead in the water, as soon as the adapter plugs into the back, the adapter's green light shuts off, and obviously no light on the laptop.

2) I don't know if I can completely rule out the battery, but I do know if I remove the battery, and still plug in the adapter, still no power.

3) Disconnecting the pin from the MB that attaches the power adapter to the motherboard, and then plugging the power into the back of the laptop, the green light on the power unit DOESN'T shut off, so it seems like the short must be coming from the MB.

4) And lastly, after removing peripheral devices individually and testing the power unit for each in case the short was elsewhere (with no success), I decided to plug the battery back in. Right as I plugged the battery back in, with the power cord unplugged from the laptop, another "pop" happened and one of the modules (no idea what to call them, btw) on the MB caught fire (which i had to blow out), another short apparently.

So, I don't quite know what to think of this. I've read online that some dells in the past have had problems with the Power connectors causing shorts: http://www.laptoptip...ower-connector/

But, although I couldn't locate the first short, the second short (obviously causing damage to the MB) came in relation to the battery. The warranty is only a few months expired, just as it was when my HD failed... Two very discouraging issues for a repeat Dell customer. It sounds like sending it in to fix is almost as much as a new laptop, but if I went the route of a new laptop, I'm now on the fence about using Dell after back to back problems. However, Im comfortable fixing it myself, but my issue is if I replace the MB, and the issue is elsewhere (like the battery or power connector), it sounds like I would risk frying the MB again, and the MBs certainly aren't cheap. I can post a pic of where the second short happened if needed, but again, Im not sure where to go from here.

Please help! Thanks!
  • 0





  • Member
  • PipPipPipPip
  • 1,929 posts
Hello PTricky and welcome to Geeks To Go.

My money would be on a faulty adapter and as you quite rightly point out it would be crazy to fit a new board and use the old adapter.

It sounds like the damage has already been done were you to buy a new adapter.

In my personal opinion it would be easier and cheaper just to buy a new laptop but not from Dell this time.
  • 1

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP