Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Alienware screen turns off randomly and takes along time to turn on

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 7 posts
Received a new Alienware laptop last week, with a 2GB nvidia geforce GTX 675M graphics card. Worked fine for the first week. The problem is the screen started shutting off for maybe 10 to 15 seconds every half hour or so. Today when I turned it on everything worked fine but screen didn't come on, so I plugged in another monitor to it (which worked fine) after about 15 minutes laptops screen finally turned on. Worked on it for 4 hours and no problems. When I got home turned it on and same problem as earlier, after about 15 minutes the screen worked fine. I've downloaded the latest drivers but other then that I've no idea as to what might be causing the problem or how to fix it. I would like to hear if anyone else has had a problem like this or any suggestions on what's causing it or how to fix it, thank you.
  • 0





  • Moderator
  • 34,114 posts
IMHO since you just bought it I would say it is a hardware issue. Since it is new your warranty should cover the repair work needed. That would be the first direction you take as anything we suggest as far as taking the system apart would result in your warranty being broken.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP