Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Logitech Speakers won't give an audio output


  • Please log in to reply

#1
HELP.ME

HELP.ME

    Member

  • Member
  • PipPip
  • 29 posts
Recently, I formatted my computer and re-installed Windows Vista. When I first booted the computer after that I discovered that my Logitech speakers hooked up to the computer didn't function anymore. I've had a similar problem in the past, and I was given the advice to download/update the motherboard driver files. I think that worked. However I'm not sure where to find these files again.

Not sure if this information helps/whether you need more but:

System Model: P5K-E
System Type: X86-based PC
Processor: Intel® Core™2 Quad CPU Q6600 @2.40GHz, 2394 Mhz, 4 Core(s), 4 Logical
BIOS: American Megatrends Inc. 1013
SMBIOS: 2.4

  • 0

Advertisements


#2
Wolfeymole

Wolfeymole

    Member

  • Member
  • PipPipPipPip
  • 1,929 posts
Try here mate.

http://support.asus....n&m=P5K-E&os=17
  • 0

#3
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,024 posts
Just to add to what Wolfey has suggested HELP.ME be sure that if you have not done so already that you install the MBs chipset drivers before any other drivers.
  • 0

#4
Wolfeymole

Wolfeymole

    Member

  • Member
  • PipPipPipPip
  • 1,929 posts
Absolutely and cheers Phil. :thumbsup:

On entering that link you will see that the default OS is XP.

Changing it to Vista 32bit will still show the same drivers for the chipset and audio.
  • 0

#5
HELP.ME

HELP.ME

    Member

  • Topic Starter
  • Member
  • PipPip
  • 29 posts
Hey guys! thanks for the help! i've tried those downloads though and they don't seem to work :/
  • 0

#6
Wolfeymole

Wolfeymole

    Member

  • Member
  • PipPipPipPip
  • 1,929 posts
A rather silly question I know but it's happened before.

You do actually have the speakers plugged into the Green socket to the right as shown in this example yes?

Posted Image
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP