Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

DLink router does not release gateway address


  • Please log in to reply

#1
chicken_little

chicken_little

    Member

  • Member
  • PipPip
  • 59 posts
My friend says i can use his unprotected wifi network whilst he is out of the country for a couple of months, my wifisky 2000mw dongle sees his dlink router with 95% signal and 90% quality, but when i click to connect i get an ip address of
169.254.64.28, i get a subnet mask of 255.255.0.0 but the gateway address never shows so i cannot use his network, i have tried a different antenna and dongle.

any ideas folks?
  • 0

Advertisements


#2
RKinner

RKinner

    Malware Expert

  • Expert
  • 17,336 posts
  • MVP
169.254.64.28 is an IP address that your computer made up. It's not a valid address obtained from the router and thus there is no gateway associated with it. Make sure that DHCP is running on your PC. (net start DHCP) Also possible that your firewall is blocking DHCP since it doesn't know the new network.

Ron
  • 0

#3
chicken_little

chicken_little

    Member

  • Topic Starter
  • Member
  • PipPip
  • 59 posts
Hi Ron,
Confirmed DHCP is running, and still no joy after disabling my windows firewall.

screenshot attached

Attached Thumbnails

  • screenshot.JPG

  • 0

#4
RKinner

RKinner

    Malware Expert

  • Expert
  • 17,336 posts
  • MVP
You can turn the Windows Firewall back on. It won't interfere. I was thinking more of third party firewalls.

What happens when you click on ReNewIP?

Could be it will work better with Windows Zero Configuration (WZC). Check the box then Close. This should allow Windows to handle the Wireless instead of Realtek's utility. My experience has been that WZC works better and more reliably. You may need to reboot to get it to take effect.
  • 0

#5
chicken_little

chicken_little

    Member

  • Topic Starter
  • Member
  • PipPip
  • 59 posts
Hi Ron,
When i click renew ip address, i get the same address with the same resulting no gateway.

I tried with WZC and it showed as connected but when i ran ipconfig there was the exact same ip address and no gateway.
See screenshot.

Attached Thumbnails

  • srceenshot2.JPG

  • 0

#6
RKinner

RKinner

    Malware Expert

  • Expert
  • 17,336 posts
  • MVP
It's possible (but odd) that DHCP is not enabled on the router. If the router is using the default IP address scheme you can try manually putting in the address. Use 192.168.0.27 for your PC's IP address with mask of 255.255.255.0 and 192.168.0.1 for the default gateway and also for the DNS server. If that doesn't work then try 192.168.1.27 and 192.168.1.1

http://www.howtogeek...a-or-windows-7/
  • 0

#7
chicken_little

chicken_little

    Member

  • Topic Starter
  • Member
  • PipPip
  • 59 posts
Hi Again Ron, thanks very much for sticking with me on this.
Same thing i'm afraid. I set the ip and mask and gateway to both sets you gave me (see screenshots),
same result, no internet.

Attached Thumbnails

  • screenshot 3.JPG
  • screenshot 4.JPG

  • 0

#8
RKinner

RKinner

    Malware Expert

  • Expert
  • 17,336 posts
  • MVP
Could be the router has MAC security enabled so it's not going to talk to people it doesn't know. I suppose the friend has already left so there is no chance of plugging directly into the router so you could check?
  • 0

#9
chicken_little

chicken_little

    Member

  • Topic Starter
  • Member
  • PipPip
  • 59 posts
Hi Ron,
i have no chance of finding out what his router settings are for a couple of months now. i don't have access to his house.

Thanks anyway for all your help/advice.

best regards, Dave.
  • 0

#10
RKinner

RKinner

    Malware Expert

  • Expert
  • 17,336 posts
  • MVP
This PC does work on other wireless networks doesn't it?

Also when you set the ip address manually, do not rely on your browser to see if it is working. From a command prompt do:

ping 192.168.0.1

or

ping 192.168.1.1
  • 0

#11
chicken_little

chicken_little

    Member

  • Topic Starter
  • Member
  • PipPip
  • 59 posts
Hi Ron,

Yes, my pc can connect to other wifi networks.

pinging on both those ip's timed out, and with 100% loss of packets.


Dave
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP