Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Hard Drive doesn't show up in BIOS


  • Please log in to reply

#1
MikeMason

MikeMason

    Member

  • Member
  • PipPipPip
  • 100 posts
Hello, I'm an advanced user so have been given this computer to fix from my cousin.

She had problems with Windows loading and when it did load. The computer would freeze after a couple of minutes. I noticed that the hard drive would show up in BIOS every now and again. So I thought it was most likely a faulty SATA cable or hard drive.

I've now tried a brand new hard drive and SATA cables but still have the same problem. I noticed when the computer is left unplugged for 30 seconds or so. The hard drive will show up in BIOS the very first time you turn on the computer. When I exit and enter BIOS again, the hard drive will not show up. It also does this for the DVD drive too. Whether the hard drive is connected or not.

I've cleared BIOS and changed the CMOS battery. Everything looks good on the motherboard. I've completely unplugged it and replugged it back in. Reseated the RAM etc but nothing.

I've came across a thread from a year ago about this Acer AX3400. The guy had the exact same problem I have with this machine. I'm guessing it's a fault with the motherboard. The motherboard seems to be generic, no manufacturer name on it. It's also strange that Acer doesn't list this model on their website. Even though it's only 3 or so years old.

Is there anything else I can do? I think I've tried everything.

Any help would be greatly appreciated.
  • 0

Advertisements


#2
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,006 posts
Hello MikeMason

Could be a problem with the SATA controller, have you checked the Device Manager for any yellow ! or red Xs.
Try reinstalling the chipset drivers http://www.acer.co.u...content/drivers

To see if you can get some MB information run Speccy and post the url for us http://www.piriform....file-to-the-web
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP