Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

disc drive not showing windows 7 pro


  • Please log in to reply

#31
Wendywoo0805

Wendywoo0805

    Member

  • Topic Starter
  • Member
  • PipPip
  • 49 posts
I have downloaded the 2 drivers...... but what do I do now as my dvd drive doesn't show in device manager?
  • 0

Advertisements


#32
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts

I have downloaded the 2 drivers...... but what do I do now as my dvd drive doesn't show in device manager?

Sorry my instructions probably was not clear... did you install both?
  • 0

#33
Wendywoo0805

Wendywoo0805

    Member

  • Topic Starter
  • Member
  • PipPip
  • 49 posts
I downloaded them both........not sure about installing as I don't know what drivers to uninstall first?

I don't want to uninstall the wrong things
  • 0

#34
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts

I downloaded them both........not sure about installing as I don't know what drivers to uninstall first?

I don't want to uninstall the wrong things


You don't need to uninstall any, you only have to install the new ones first the Chipset then the other one for SATA.
  • 0

#35
Wendywoo0805

Wendywoo0805

    Member

  • Topic Starter
  • Member
  • PipPip
  • 49 posts
tried to install the chipset one and it says its not for this pc......... installed the other and now dvd is not showing at all even if I put a disc in......

I put in my serial number/model etc on the acer site...........so it should have been the correct driver info I was given

Edited by Wendywoo0805, 13 August 2013 - 02:51 PM.

  • 0

#36
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts

tried to install the chipset one and it says its not for this pc......... installed the other and now dvd is not showing at all even if I put a disc in......

I put in my serial number/model etc on the acer site...........so it should have been the correct driver info I was given

Is this one the file for the chipset you installed Chipset_Intel_8.15.10.1808_W7x86W7x64_A.zip?

Edited by SleepyDude, 13 August 2013 - 02:57 PM.

  • 0

#37
Wendywoo0805

Wendywoo0805

    Member

  • Topic Starter
  • Member
  • PipPip
  • 49 posts
Chipset_Intel_8.15.10.1808_W7x86W7x64 is the one that windows would not install as it said it was the wrong driver even tho its what I got from the Acer site for my model etc
  • 0

#38
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts

Chipset_Intel_8.15.10.1808_W7x86W7x64 is the one that windows would not install as it said it was the wrong driver even tho its what I got from the Acer site for my model etc


Its strange but isn't the first time I found a situation like that, eventually you got and updated driver from Windows Update...

I want you to try a Clean Boot by following this article after the clean boot check if the DVD drive works and if you can access the files on the discs.
  • 0

#39
Wendywoo0805

Wendywoo0805

    Member

  • Topic Starter
  • Member
  • PipPip
  • 49 posts
Hi.... I really needed to get it working so I can install other software etc so today I gave up and took it to a techy recommended by frends......
I really appreciate all the help from you but felt this sas maybe an awkward one to do at a distance.....

J will let you know if it gets fixed and what the eventual solution was tho...other than a large heavy hammer I mean lol.....
  • 0

#40
Wolfeymole

Wolfeymole

    Member

  • Member
  • PipPipPipPip
  • 1,929 posts
Get the tech to check the ribbon cable and its connections to the drive interface and the motherboard Wendy. :cheers:
  • 0

Advertisements


#41
Wendywoo0805

Wendywoo0805

    Member

  • Topic Starter
  • Member
  • PipPip
  • 49 posts
I shall .....thankyou :-)
  • 0

#42
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts
Ok Wendy.

It would be nice to hear from you what was the problem.
I'm betting in a software problem because the drive works in Safe Mode and during boot.
  • 0

#43
Wolfeymole

Wolfeymole

    Member

  • Member
  • PipPipPipPip
  • 1,929 posts
If the tech fixes it treat him to a pint of heavy and a chaser.
  • 0

#44
Wendywoo0805

Wendywoo0805

    Member

  • Topic Starter
  • Member
  • PipPip
  • 49 posts
Going to collect now....corrupt registry apparently and he also found a virus....so much for MSE being a great free anti virus lol.......
  • 0

#45
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts

Going to collect now....corrupt registry apparently and he also found a virus....so much for MSE being a great free anti virus lol.......

Hi,

Thanks for the report :) Hum a virus something that crossed my mind but I wasn't sure...
No Antivirus is perfect every one can miss something...
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP