Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

AHCI port1 device error


  • Please log in to reply

#1
mysticaries88

mysticaries88

    Member

  • Member
  • PipPip
  • 15 posts
I have a previously owned TOSHIBA Satellite M505 S4945

On saturday I got this pop up 'windows detected a hard disk problem'. (not my photo, but this is the same type of pop up) 110jihc.png
I googled and found a "fix" : TYPE gpedit.msc ON RUN. Navigate to Computer Configuration\Administrative Templates\System\Troubleshooting and Diagnostics\Disk Diagnostic...Double Click on "Disk diagnostic: configure execution level", set it to "disabled". "Not configured" is enabled by default.

Sunday my laptop turned off/restarted and I got this error page that doesnt show up on my laptop, but shows up on my tv (hdmi connected) 20130819_184919.jpg
20130819_184849.jpg

I noticed the "AHCI port1 device error" all the way in the bottom. I did some research, but would like to know any and all reasons why I would get this error...

Extra info: On Friday night my laptop slammed shut fairly hard (it doesnt stand up on its own) I did open my hard drive area and noticed that the hard drive was crooked and being held by cardboard (not done by me).
20130818_194108.jpg This the hard drive that I straightened out, but laptop still shuts off.
20130818_194141.jpg This is for just in case you need it...

So why is this happening and what can be done? Thanks in advance! :thumbsup:

Edited by mysticaries88, 20 August 2013 - 04:55 PM.

  • 0

Advertisements


#2
Wolfeymole

Wolfeymole

    Member

  • Member
  • PipPipPipPip
  • 1,929 posts
Looks to me like your hard drive is dead mate.
  • 0

#3
mysticaries88

mysticaries88

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Ok thanks! By the way, almost every time my pc shuts off there's a quick flash of a blue screen with white writing...So if I need a new hard drive, what do you recommend? And what should I get to transfer hard drive data? Thanks!
  • 0

#4
Wolfeymole

Wolfeymole

    Member

  • Member
  • PipPipPipPip
  • 1,929 posts
Well any SATA hard drive will do, it depends on your budget and do you have the OEM installation disk or Back to factory recovery disks for Vista?
  • 0

#5
mysticaries88

mysticaries88

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
I think I have a disk (not original though) PC was a hand me down/gift with windows 7 already installed. And ok thanks a bunch for the hard drive advice :)
  • 0

#6
Wolfeymole

Wolfeymole

    Member

  • Member
  • PipPipPipPip
  • 1,929 posts
Ok, so what is the disk that you have now?

Windows 7 or Vista?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP