Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Anomalous display driver crashes


  • Please log in to reply

#1
averysadman

averysadman

    Member

  • Member
  • PipPipPip
  • 176 posts
I've started getting anomalous "The display driver has stopped responding but has recovered" errors, but only during certain games. The game will hang, the screen will go black, Windows will switch from Aero to basic for a split second, then I'll get the system tray error message and the game will be black and unresponsive.
I'm using an AMD Radeon 5850 with Catalyst 13.1 drivers.

So far I have ruled out:

-Heat, the GPU never passes 58°C and it's operating temperature is 90°C
-VRAM, in the games that crash my VRAM usage is only around 700/1012Mb
-CPU load, I can play much more demanding games with no issues
-RAM, I barely use 5 of my 8Gb in these games
-GPU load, I've played much more demanding games for extended periods that don't crash
-GPU seating/cables, the issue is only present in certain games
-Window mode, I thought that perhaps tabbing out of games or running them windowed was causing it, but after tests the games that crash do so regardless
-Drivers, mine are up to date and stable
-Overclock, the problem is limited to certain games and my OC is very stable and has been in place for about two years

At the moment the only games that are causing this problem are Two Worlds 2 and Sleeping Dogs, as far as I know they have nothing in common, and the crash doesn't seem to be triggered by anything in-game. I've never experienced this issue before.

Any advice is greatly appreciated as I have exhausted my options.
  • 0

Advertisements


#2
JohnSheen

JohnSheen

    Member

  • Member
  • PipPip
  • 62 posts
Hello, averysadman.

My name is JohnSheen and I will try to help you with your problem :)

This problem is usually caused by unstable overclocking.

The needs of applications differs much from one another. I have an overclocked 5850 too, and while overclocking it every game works well, benchmarks comes off clean, but when I run Crysis 2 and especially Crysis 3, the drivers stop responding. The others work fine. I totally understand you. But, this means there is a problem with your OC clocks.

Now,

Please tell me at what clocks you are running your HD5850? and also Voltage of course :) Assuming you did not flash the BIOS, as you did not stated above.
And which tool do you use, trixx, MSI Afterburner or something else I cant remember its name right now :D

In the meantime, (optional) please update your drivers to 13.10 beta version. Not necessary, but better with the new ones :)

So, take care friends, hopefully it wont take long to solve this problem :)

Peace

Edited by JohnSheen, 07 September 2013 - 03:06 PM.

  • 0

#3
averysadman

averysadman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 176 posts
Hi, thanks for your reply.

My overclock is 800MHz on the GPU and 1000MHz (stock) on the memory. Voltage is 1.15V, slightly above the 1.12V stock. I used Catalyst Control Center and tested the clocks in Furmark for extended periods.

I doubt it's the overclock, as it's only happening in two games that aren't very graphically demanding and were installed fairly recently. I can play Battlefield 3, Crysis 2, Crysis Warhead, Farcry 3 etc without issues. I've had this clock for around two years without a single problem until now (possibly).
There's a very easy way to check though, I'll just lower my clocks to stock and test the games.

Nice to see someone else still rocking a 5850 by the way, they're great cards, I'm still hesitant to replace mine as it still plays everything in max settings.

I'll get back to you.

Edited by averysadman, 07 September 2013 - 09:07 PM.

  • 0

#4
JohnSheen

JohnSheen

    Member

  • Member
  • PipPip
  • 62 posts
Hi, avery,

Yeah, 5850's are awesome and have gigantic OC headroom :D I would only replace it for an HD 7970, but we should see what future brings :) AMD is going to release its new series in 3 weeks :)


Please download the tool linked below, because CCC wont be much of a help :)

Beta 14 of MSI Afterburner,

MSI Afterburner Beta 14

Well, from what I see, it is only a little OC, however your core voltage is too high for 800Mhz core clock. Stock voltages should be around 1.087 V for hd5850. But, every card is different, please check your core voltage with msı afterburner.

Set up the program, go to settings and check "Unlock Voltage Control, Unlock Voltage Monitoring" also go to the FAN tab above, and check "Enable user defined software automatic fan control." And check, "Extend Official Overclock Limits" we will be using MSI not CCC :)


And lastly, download,

Gpu-z

or from here,

Gpu-Z


We will be checking for your voltages and stability, it is a great monitoring program for your GPU, the voltages and current readings are useful :)

Waiting for your update
Take care
Peace

Edited by JohnSheen, 08 September 2013 - 04:21 AM.

  • 0

#5
averysadman

averysadman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 176 posts
Hi.

Ok so the games still crashed on stock clocks, 725MHz. Sleeping Dogs then played for a long time at 800MHz but eventually crashed again. I also tried both games with Chrome closed, incase that might have affected somthing, no change.

I already have MSI Afterburner installed, I use it to monitor VRAM load in-game with the overlay. MSI doesn't work very well for overclocking on my system, the clocks I set with it don't stick, and it doesn't allow me to view or change the voltage. I use a .ini file in the Catalyst drivers to set the voltage and disable powerplay, as CCC only allows me to set the clock speeds with no voltage options. Like I said I've had this overclock for years though, since Crysis 2 came out infact, that was what made me start overclocking originally.

I've installed GPU-Z, what information do you need from it? It shows my voltage at 1.150V.
  • 0

#6
JohnSheen

JohnSheen

    Member

  • Member
  • PipPip
  • 62 posts
Ok,

Please download latest beta 14 Msı Afterburner, and check the boxes I told you in my previous post.

MSI Afterburner Guide

Read this one, it will save me from writing a long post :D Apply the steps, MSI Afterburner is the one and only tool for voltages and clocks. I use it myself and had no problem at all. You can set profiles, but dont forget to save them. But no matter what you adjust, always do it one at a time. Never adjust two parameters at the same time. And check the little dot at he down left corner which says "Apply overclocking at system startup"

And from settings (right down corner) from general properties check the boxes "Start with Windows and Start minimized"

Anyway, for your solution, please bump the core voltage of your GPU by 6 mV = 0.006 V .
Try your games again, and if not helps, try another 6 mV.

Your core voltages are too high for 800 Mhz ( I run mine at 860 Mhz , 1.125 V ), but this is what saved me from getting display driver crash errors from Crysis 3 after overclock.

Also, if you are still getting the same error, please increase your core clock speed by 10Mhz. and another 10 if still there. Dont worry, especially after you increased your voltage there will be plenty of room for OC in this voltage settings. This is basically what happened with my 5850 and how I solved it. I can not guarantee but it should help ;)


Waiting for feedback,
I think this will help.

Take care,
Peace

Edited by JohnSheen, 08 September 2013 - 12:37 PM.

  • 0

#7
averysadman

averysadman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 176 posts
I have done what you said with MSI, but it does not allow me to view or change the voltage.
Screenshot provided.
I have used MSI before and encountered this problem with my card, which is why I don't use it as my main OC utility. I tried about 4 different tools back when I first started overclocking and so far the only thing that allows me to view or change my voltage is editing the Catalyst files directly.
800MHz seems to be the limit for this chip, even at 1.15V if I try to go any higher, such as 805 or 810, I start to get artifacts in Furmark and the Catalyst utility and the card becomes unstable. Depending on where you got your GPU from, the quality of the chip may differ, what is stable for one card may not be for another even if they're an identical model, people generally refer to it as the Silicone Lottery. Although I'd sure as [bleep] like to run mine at 860MHz, I've heard of people getting as high as 1GHz with 5850s, using water blocks of course.

By bump my voltages, do you mean reduce them? It's possibly I'm using too much power for 800MHz like you say, I never tweaked the voltage too much, just found something that worked and stuck with it. Would voltage alone result in display driver crashes though, and why in so few games? I would expect stressful games like Crysis to cause such crashes.

Attached Thumbnails

  • msi.jpg

  • 0

#8
JohnSheen

JohnSheen

    Member

  • Member
  • PipPip
  • 62 posts
Hello avery,

I want you to remove your version of MSI Afterburner and set up the 3.0.14 beta version(I linked in my previous posts)., because it is an old one and MSI Afterburner upgraded itself greatly since your version.


And please read the article I linked in my previous post which is about allowing unofficial OC through .cfg file of MSI Afterburner. And apply the steps provided.

You should not get these artifacts slightly above 800, it is a very light overclock, it is right that not every chip is same but, it is usually the lottery if you can get past 1Ghz or not. The lottery is never passing 800 mhz ;)

I myself did not push the card too much because the fan noise drives me crazy and above 900 I would have to run the fans at 60% or so, still mine is a light overclock too :)

By bumping I mean increasing them by 6mV increments.

And lastly, you have not provided me information on your system specs, especially your PSU, so I cant make further comments on the unstability of your card above 800mhz.

Please apply these steps, and try again what I said in my last post. Then give an update please.

Take care,

Peace
  • 0

#9
averysadman

averysadman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 176 posts
Hi, thanks for your reply.

Are you sure overvolting further is a good idea? I hear that's a good way to damage your card. Currently at 800MHz and 1.15V my card gets to about 70°C in Furmark and 60°C in demanding games like Battlefield 3 with the fans forced to 100%. I know it can get to about 90°C before heat becomes a real issue, but still.
I'll do as you say and see if I can get MSI working properly then, if so I'll try overclocking some more. I can always revert to CCC's profiles if I encounter a problem.

My PSU is a 500W Antec Eco, I think it has more than enough power for my purposes.

Ok, first problem.
The guide says to open MSIAfterburner.cfg and edit the following value:
EnableUnofficialOverclocking = 0

However I have two MSIAfterburner.cfg files.
The first has these values:

[ATIADLHAL]
UnofficialOverclockingEULA =
UnofficialOverclockingMode = 0
UnofficialOverclockingDrvReset = 1
AccessibilityCheckingPeriod = 0
UnifiedMemoryUsageMonitoring = 1

The second has these:

[ATIADLHAL]
UnofficialOverclockingMode=0
UnofficialOverclockingDrvReset=1

Which should I edit? One or both? I assume 'UnofficialOverclockingMode' is the equivalent of 'EnableUnofficialOverclocking'.

Edited by averysadman, 09 September 2013 - 09:26 AM.

  • 0

#10
JohnSheen

JohnSheen

    Member

  • Member
  • PipPip
  • 62 posts
You should have one actually in the directory, did you remove your older version and downloaded the new one? Anyway it should look like the first one you posted.

Wow, fans at 100% and 70degrees... Are you the first owner of the card?

Well, I am just telling what I did to fix the problem.

Were the voltages this high when you overclocked it the first time? and is the card overclocked previously by any other person? And do you have enough air circulation in your case? Because what you are telling me are not good signs and you may have to replace your card in following weeks, after AMD releases its new series, hopefully sending the prices of the older ones down.

You downloaded GPU-Z right.

Well, please download Valley benchmark from Unigine, set up and follow the steps I am going to tell you, I want the readings on the following sensors on GPU-Z, screenshots if possible (but not necessary)

UNIGINE Valley


1) As you are running the benchmark, set the settings at maximum possible, but please uncheck Fullscreen, you will have to run GPU-Z at the same time and pay attention to the ;

- Temps,
-VDDC readings,
-VDDC Current readings. (this one is very important, we must be sure your card gets enough power from your PSU) (check for the max and min values, especially min values)
-Check the core clock and see if there are any unstabilities during the valley benchmark.

That's it for now, as I told you these are signs of an unstable OC.

Also, download speed fan an other all around monitoring program,

Speed fan

Here, I want you to check the voltage readings on every rail especially 12v and 5v rails.

Please apply these steps before overclocking or overvolting now your card seems despereate and pushing it wont help at all.

Waiting for your update,
Take care
Peace

Edited by JohnSheen, 09 September 2013 - 10:04 AM.

  • 0

Advertisements


#11
averysadman

averysadman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 176 posts
Yes I'm the first owner, but this card is from 2009, so it's been running for nearly 5 years, overclocked for a lot of that.
I have very good cooling, Corsair 500R case, 240mm fan blowing directly onto the GPU, very good temps on all other components. My overclock has always been 800MHz at 1.15V, that's as high as I thought I could get because like I said, once I pass 800MHz I start getting artifacts. My card is a Club3D Radeon HD5850, has a single push fan, decent heat pipes.

I already have Unigine Valley installed so I can do that right away.
I ran it in Ultra HD preset, I left it fullscreen because I have multiple monitors and could still monitor GPU-Z.

VDDC was totally stable the entire time, no drops or rises.
Both core and memory temperatures were normal, didn't exceed 55°C in this benchmark, no drops or rises during the benchmark.
File included is a screenshot from just after the benchmark ended, I can also provide a GPU-Z sensor log if you need it.

I've installed Speedfan but it only seems to detect two of my fans.
I have:
-Two fans on the front panel
-One 240mm fan on the side panel
-One exhaust fan at the back
-One CPU fan
-One GPU fan
-One PSU fan

I've included a screenshot of Speedfan, I'm not sure how to read it.

Attached Thumbnails

  • GPUZ.gif
  • speedfan.jpg

  • 0

#12
JohnSheen

JohnSheen

    Member

  • Member
  • PipPip
  • 62 posts
hmm, ok in your next post I want you to note the minimum and maximum values of VDDC Current reading.

screeenshot.gif

I posted the screenshot from my gpu-z and it is right below the VDDC box, scroll down if there is any chance. During the benchmark, please check out the min and max values. I want to cross out the PSU from possible defected list ;) your voltage readings are good as shown in speedfan, nothing abnormal. (If there is no vddc current reading part in your gpu-z sensor tab, then we have to assume your PSU is running well, judging only from your voltage readings. and please skip to set up and settings part of MSI afterburner)

Set up MSI Afterburner's beta 14, and send me the min and max values of VDDC Current readings from GPU-Z.

We will get back to GPU based solutions after on ;)

Take care,
Good night
  • 0

#13
averysadman

averysadman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 176 posts
Unfortunately GPU-Z doesn't seem to have those options for me, I assume my hardware doesn't support it. Mine stops at VDDC.

I've followed the instructions you linked, but nothing I do will let me see Voltage settings in Afterburner. I edited the .cfg correctly and got a disclaimer message when starting up MSI, which means the unofficial overclocking is active, but I still can't see the voltage. Core Voltage (mV) and Power Limit (%) are still blank. The .cfg is edited correctly, and the options are enabled in the settings.
If I remember I had this same problem back when I first started overclocking which is why I didn't use MSI, if you remember I said the only way I had found to change my voltage so far was by editing files in the drivers.
  • 0

#14
JohnSheen

JohnSheen

    Member

  • Member
  • PipPip
  • 62 posts
Then your card is voltage locked in this case...

Well, avery I guess you can deal wit the voltages from CCC.

First of alll, what you were saying about your card did not sound right to me. And I did some further research to be sure. What I reached is, your 5850 is most probably damaged and that's why you cant overclock it anymore and having too high temps regardless of 100% fanspeed.

It seems you could not push it too hard from the very beginning because it did not allow you to. So, your card may be defected from the beginning.

IMPORTANT: If you have the opportunity, please try mounting your card in another system. Your friends or cousins or someone :D And check the same core clocks and voltages in their system, I mean the OC you applied. And check if the gpu behaves the same, giving artifacts slightly above 800mhz and overheating with fans running at 100%. Because your card is not stable right now, the display crashes is a sign of this unstability. Every game behaves different of course, but this is for sure.

Now, please undervolt your gpu core voltage, by 6mV gradually till you reach, 1.1 volt from 1.15V.

-Try your games again and please check for any difrerence in Temps during benchmarks. (through gpu-z and hwmonitor) ( they should be lower now)

Also remove speedfan and install HWMonitor for temps. a more reliable program

HW Monitor

-then run Memtest86 to make sure your RAM s are Ok. the problem may be caused by your RAMs. just to cross things out

Memtest86

- Finally, run the FIX IT by microsoft linked below, ( I am assuming you are using Win 7)

Microsoft fix it

Please update me,
I am still betting on gpu regarding the signs it is showing, but these are some tests and stuff that may help and cross out other hardware components from the list.

Take care,
Have a good day
  • 0

#15
averysadman

averysadman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 176 posts
Hi.

Memtest shows no problems.

I actually already looked at that Microsoft page while searching for a solution. It mentions:
Method 1: Increase the GPU (Graphics Processing Unit) processing time by adjusting the Timeout Detection and Recovery registry value.

Do you think that's a good idea? I don't know exactly what values that changes or how it might affect other programs or games.

I'll try undervolting some more and get back to you regarding the temps.

For reference this is how I manage the voltage.
I open up AppData\Local\ATI\ACE\Profiles and create .XML files with the desired values.
eg:

</Feature>
<Feature name="AutoTuneSupport" />
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="80000" />
<Property name="Want_1" value="80000" />
<Property name="Want_2" value="80000" />
</Feature>
<Feature name="PowerControl_0">
<Property name="Want" value="0" />
</Feature>
<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="100000" />
<Property name="Want_1" value="100000" />
<Property name="Want_2" value="100000" />
</Feature>
<Feature name="CoreVoltageTarget_0">
<Property name="Want_0" value="1150" />
<Property name="Want_1" value="1150" />
<Property name="Want_2" value="1150" />
</Feature>
<Feature name="MemoryVoltageTarget_0">
<Property name="Want_0" value="0" />
<Property name="Want_1" value="0" />
<Property name="Want_2" value="0" />

Ok so far I'm down to 1.134V with seemingly no change in stability and a full 15°C shaved off the Furmark temps :D

I'm running a few games to make sure it's stable, and to test for display driver crashes.

Edited by averysadman, 13 September 2013 - 02:06 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP