Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Just checking computer is clean


  • Please log in to reply

#16
ozegirl

ozegirl

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 375 posts

If you want to change how often a task runs then right click on in the top pane and select Properties then Triggers then Edit.


Yep understand all that but:

Some of the other tasks I was going to edit from once a day to once a week or month but although I could alter this setting, the OK button at the bottom required to save the new setting became greyed out as soon as I did so, which meant I couldn't make the change. Tried running as administrator too.


... maybe this is getting outside of the scope of this thread...

I have uninstalled, or disabled, or taken out of startup quite a few unnecessary programs and things run a bit faster now :)

I checked out the scheduled task and it's pcalua/exe - a compatabilty assistant, so I'll leave it.

Rather than download Process Explorer again I just ran task manager and System idle was at 98%, only explorer and task manager itself were taking up any CPU. Sweet. MSE looks as though it is behaving now. I think MSE was probably just hogging at the time because it was probably updating or scanning.
  • 0

Advertisements


#17
RKinner

RKinner

    Malware Expert

  • Expert
  • 20,029 posts
  • MVP
Sounds like it is working OK.

If Task Scheduler is still giving you trouble you can look in the registry:


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\

Right click on Schedule and select Permissions. Then find Administrators or your own login and click on it. Make sure it has Full Control checked. Repeat for:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\CompatibilityAdapter\Signatures

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache

(and all of its keys)

Then open Windows Explorer and go to

C:\Windows\Tasks

right click on Tasks and select Properties then Security. Verify that Administrators have Full Control as before.

Repeat for any of the tasks within the folder that are giving you trouble.

Also look in:

C:\Windows\System32\Tasks


If the permissions are all OK then try booting into Safe Mode and see if it then allows you to make the changes. There may be a program that doesn't want the task changed.
  • 0

#18
ozegirl

ozegirl

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 375 posts
I very strongly recommend you add another line to any instructions involving the registry:

First backup registry!

I should have known better myself, but being tired and in a bit of a hurry (never a good time to tinker with computers) I forgot this important step.

I started making the changes you suggested to the registry - didn't make any difference

I then went to C:\Windows\Tasks & had full control as admin, but there wasn't anything much there in that folder other than a log.

then went to C:\Windows\System32\Tasks and found this was the location for the tasks. I changed admin permissions to full control for the overall folder but still no change. There were quite a few sub-folders for tasks and it was at this stage I wondered if it was really worth it. I am able to disable or nuke tasks, maybe easier to do that and then re-create a new one.

Anyway I thought I would reset the settings as they were but then realised that the settings before for admin were read only and special permissions - but of course I had no idea what those special permissions were as I didn't check before changing to full control. It was at this point I slapped my forehead & called myself an idiot for not backing up the registry.

I figured that maybe the settings are that way for a reason & checking on another computer I have the same settings (ie can't change the task schedule). Didn't want to go ahead with more changes as I don't want to open a vulnerability for something to run tasks that might be malicious....anyway I have just decided to let this one go as otherwise I'm going to end up mucking up some important task or cause some other problem.

Maybe when at some stage I have more time and energy I can try this again but use my Acronis "Try & Decide" tool which is like a virtual machine/sandbox thingy, and/or backup the registry first. For now I have other non-computer related tasks calling for my attention....

Thanks again for all your help :)
  • 0

#19
RKinner

RKinner

    Malware Expert

  • Expert
  • 20,029 posts
  • MVP
Permissions I told you to look for were exactly like what my Win 7 has so I don't know why yours were read only. That's not normal.
  • 0

#20
ozegirl

ozegirl

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 375 posts
Ok I have had more time to look into this and I now realise I was misled in thinking that I couldn 't change things in Task Scheduler. I had based this on the fact that when I tried to change a schedule from weekly to monthly, the OK button immediately became greyed out. This morning I also set the months (OK still greyed out) and chose a day (OK still greyed out) but then when clicking out of that selection box the OK came "up". I just didn't realise those things had to be specified, as I had a "Starting from" date & time at the top I had just presumed it would be monthly, starting from that date & time. Never having been into Task Scheduler before I thought those options to set months and dates were just that - options, if you wished to be more specific. But now I know that they need to be set :) All good.
  • 0

#21
ozegirl

ozegirl

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 375 posts
Think this one is solved thanks :happy:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP