Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

UEFI Dual Boot Setup: Install Ubuntu Precise alongside Windows 8

  • Please log in to reply




  • Member
  • PipPipPip
  • 170 posts

I'd like to install Ubuntu alongside Windows 8 in my new Toshiba Satellite laptop, which has EFI (instead of BIOS).

I've spent almost the entire last 24 hours trying to create a USB drive that the Toshiba will boot from, to no avail.
I have, however, learned how to reliably access the EFI settings and select a boot device - neither of which, it turns out, are performed by pressing any keys during boot-up. Little victories.

Anyways, I've got a different desktop that's running Ubuntu 13.10, so my goal is to use that machine to create the USB drive that will install Ubuntu on the laptop.

Of course, I could also use Windows 8 to create the USB drive; it's just a matter of what's easiest.

Approaches I've tried:

1. Startup Disk Creator (using ubuntu-12.04.3-desktop-i386.iso as installation image) to create a bootable USB drive. The USB drive then boots on my desktop PC (which has a BIOS, not UEFI), but does not boot on the laptop. Possible reason may be that the filesystem format is vfat instead of fat32. UEFI Error Message: "System doesn't have any USB boot option. Select another device."
2. I have downloaded & installed elilo - a linux command-line utility for installing the EFI boot loader - but I do not have sufficient knowledge of how to use elilo to really do anything with it.

1. Formatted the USB drive as fat32 using diskparted (also tried graphical install via right-click->Format), then mounted the appropriate iso image, then copy-pasted all the files from the Ubuntu image to the USB drive. UEFI does not detect this as bootable. UEFI Error Message: "System doesn't have any USB boot option. Select another device."
2. Tried using WinUSB Maker, but WinUSB Maker complains that the iso file is corrupted or inauthentic or something. I believe this to be inaccurate. The error message says something about Nt.6 or NTX6 or something like that.

Before you refer me to Google, I've already found a good deal of info on this topic. The problem is, I don't really understand the info that I've found. What I have learned of the issue is the following:

1) In order to be recognized by EFI as "bootable," the file system must be fat32
2) There is some connection to .efi files and a directory called /boot/efi
3) elilo is a command-line tool to "install EFI boot loader."

My problems:

1) "Startup Disk Creator" seems to create vfat filesystems. I assume this is a problem since fat32 is necessary according to UEFI spec. Is there any way to change this so Startup Disk Creator uses the correct file system?
2) I've got elilo installed on the desktop PC, but I'm not sure how to proceed with using it to achieve this goal?
3) WinUSB Maker doesn't want to make a bootable USB for me... Because it thinks my iso is invalid.. But I'm fairly sure it's not. Any suggestions?
4) Using diskparted on Windows 8 might be a good start, but it would seem that merely copy-pasting files onto a drive is not enough for it to be recognized as bootable.

Thanks for your time guys, and have a great day!
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP