Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

svchost hangs my computer


  • Please log in to reply

#1
Fred60

Fred60

    Member

  • Member
  • PipPip
  • 82 posts
Svchost hangs my computer by taking 98% of the CPU time. After looking around a bit, I find that it has something to do with Windows update. The only way I can get the computer to run normally is to disable Automatic Updates. I confirmed that it has to do with auto updates by going to Microsoft Update page. When I did a manual search for updated at the Microsoft site, everything hung up and looking at the Task Manager i found svchost at the top using 98% of the CPU time. The Microsoft was continually searching until I ended the svchost process.

picture of the microsoft site attached.

Doing a Google search, it looks like I'm not the only one with the problem. Is this a known bug with a fix? or is it a nasty by Microsoft to try to get people to upgrade to a newer system? I don't want to have to leave Auto Updates disabled and I have no desire to leave XP.

Attached Thumbnails

  • Service Host.JPG

  • 0

Advertisements


#2
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
No fix that I know of. All you can do is disable Automatic Windows Update.

Control Panel, System, Automatic Update tab, Disable.

Windows XP only. I think Microsoft is trying to force people to get off XP!!!!! A clean install of XP that used to take 2 hours now takes 2 days because of the update problem.
  • 1

#3
the.hoarse.whisperer

the.hoarse.whisperer

    New Member

  • Member
  • Pip
  • 3 posts
Its not enough to turn automatic updates off in the Control Panel you MUST disable the service as well.
  • 1

#4
Fred60

Fred60

    Member

  • Topic Starter
  • Member
  • PipPip
  • 82 posts

Its not enough to turn automatic updates off in the Control Panel you MUST disable the service as well.


OK, how do I do that?
  • 0

#5
the.hoarse.whisperer

the.hoarse.whisperer

    New Member

  • Member
  • Pip
  • 3 posts
Start->Run->services.msc
Click on Automatic Updates in alphabetical list of services
Change startup type to disabled
  • 1

#6
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
So far, disabling Automatic Updates has worked for me.

Did it not work for you?
  • 0

#7
the.hoarse.whisperer

the.hoarse.whisperer

    New Member

  • Member
  • Pip
  • 3 posts
It did for a while and then I found problem came back. Control panel Automatic Updates was turned off but Automatic Update service was enabled. Turning off service stopped Svchost PID 1116 starting up and taking up 80% CPU activity.Only took me 12 hours to sort it !
  • 0

#8
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
That's good to know, thanks.

I sure wish Microsoft would fix it!
  • 0

#9
Fred60

Fred60

    Member

  • Topic Starter
  • Member
  • PipPip
  • 82 posts
Thanks, that took care of it for now :thumbsup:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP