Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

New videocard, computer having problems

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
So I just got an XFX GeForce 6600 GT AGP, and replaced the old GeForce FX5200 in the AGP slot on my Dell GX270. I get the latest drivers for it after the hardware is in, and everything seems to be working fine. I load up TrackMania and the screen goes black for a few seconds and then goes into standby mode, and I had the sound on and it sounded like the computer froze. After restarting I tried again with Full Spectrum Warrior, and I was able to play around in the menu and everything, but when I hit "Start game" as soon as the game loaded up it did the same thing. Can anyone help?
  • 0




    Retired Staff

  • Retired Staff
  • 2,089 posts
Hi and welcome go Geeks to Go. If you didn't completely remove the previous graphics driver this could be your problem. Go to http://www.drivercleaner.net/ and get Driver Cleaner (it is free). Then go to add/remove programs and remove the currently installed video driver. Then boot into safe mode and run driver cleaner TWICE, each time deleting all that it finds. Then re-boot and install the current driver.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP