Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Data Recovery Issue

  • Please log in to reply




  • Member
  • PipPip
  • 12 posts
I enabled bitlocker encryption on my 1 drive and then I turn it off.
everything was working fine.
Then when I reboot my system I saw that my drive is nt accessible, I have to format it.
I have dual boot with redhat and I try to access it from there I got an error when I try to mount it invalid ntfs signature.
I tried bt5, ubuntu to access it but I am nt able to get access to, only 1 option is showing format.
I mean What the..., bitlocker encryption.
Guys I need your help bady I have 250gb data on it, I dunno what to do now .
I already tried following tools
segate file recovery software
EASEUS Data Recovery
remo recover windows
stellar phonix data recover system

and still googling

Help guys

Edited by CompCav, 19 January 2014 - 03:07 PM.
removed profanity

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP