Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Sony Vaio laptop not working

Vaio laptop

  • Please log in to reply

#1
sevenbreez

sevenbreez

    New Member

  • Member
  • Pip
  • 2 posts

Have a Sony Vaio laptop (VGN-CS320J) not turning on. The charge light would light when plugged in, but would go off when power button was pushed, then reappear after a few seconds. Nothing else. No beeps, other lights, monitor, nothing. Sent to Sony and was told MB bad and they could fix for $650. I said uh....no. Got it back and bought a used MB (A1730819A) off Ebay that was supposedly tested and from a reputable seller. (Means nothing I know, it was used)

 

Now it still doesn't work, but acting differently. No beeps or monitor, but the light bar on the front lights from blue to white and goes off. Dvd drive will open. CPU fan not working. The small power light does not come on. Press and hold power button for a few seconds and light bar lights up white and goes off. Plug in charger, charge light lights and light bar turns green. It appears it is trying to turn on. I even tried putting the old MB back in only to find the same original problem I had in the first place. So something definitely changed. Back with the "new" board I've stripped it down taking out the memory, hard drive, and dvd drive. I've tried headphones to listen for beeps. Nothing. External monitor also gives me nothing. I've checked every connection 3 or 4 times. Monitor won't even flicker.

 

My guess is I got a replacement motherboard that is also bad. Seems logical, but I thought I'd give this forum a shot. Thanks.


  • 0

Advertisements


#2
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,024 posts

:welcome:   sevenbreez

 

Couple of questions if I may;

 

What happened with the original MB as in did it simply not boot up successfully one day or were there previous problems, if previous problems can you please tell us about them.

Could you at any time hear the cooling fan working when you had the initial problem with the original MB.

Are the battery and AC adapter that you have the ones that were originally provided with the notebook.

Is/was the DC power jack port on the original MB in good order and not disconnected from the MB or worn.


  • 0

#3
sevenbreez

sevenbreez

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts

It just simply would not turn one day. Worked fine before, no history of problems. No cooling fan previously with other MB either, nothing at all except the occasional charge light which shut off as soon as I would press the power button. Same  original battery. Tried both original charger and a new one I had. DC power port jack previously replaced by Sony under a bulletin about two years ago.


  • 0






Similar Topics


Also tagged with one or more of these keywords: Vaio, laptop

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP