Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

laptop wont boot, black screen

boot black screen laptop vista win7 toshiba logo toshiba satelite satelite p300 toshiba

  • Please log in to reply

#1
shaz

shaz

    Member

  • Member
  • PipPipPip
  • 147 posts

Hi I have a toshiba satelite p300....all im getting when laptop starts up is the toshiba logo, with the f2 startup option or f12 boot option...i can click on either one of those and will take me to that area.....otherwise once the logo disappears...the computer goes blank, u can still hear it loading in the background and can press keys and hear the noise from it.....at the time when screen went blank, it had a bit of a fall, maybe 2-3 ft from table to ground....any ideas what i can do, i checked the ram slots and they seem to be fine, also did the unplug battery and adapter and hold down on button to drain the power, then put adapter back in to see if that wud help but no such luck....any ideas wud be greatly appreciated''

 

regards

 

sharon


  • 0

Advertisements


#2
paws

paws

    WTT Tech Teacher

  • Tech Academy Moderator
  • 963 posts

Hi Sharon, Sorry to hear of the problem with your laptop.

When a computer falls to the ground its likely that the hard drive could have been damaged, preventing the computer from starting,

Its worth trying to boot from your Windows installation or Recovery disc if you have one.

I would be inclined to download (on a different computer) a live distro of Linux ( Puppy is good) burn the .iso to a CD ( burn it as an image (a simple copy won't work) and try and boot from it.

This will test the rest of your hardware (if it works Ok then its likely that the rest of your hardware,excluding your hard drive is OK)

If Puppy can't run then you have either most likely done it incorrectly or your hardware is damaged.

If the hardware is Ok then its worth considering buying a new hard drive, installing it ( only a two or three minute job) and then installing Windows and all your applications again.

You then will need to configure your system and copy across all your data files, photos, documents etc from your back ups.... its usually best to allow a complete half day or even longer to do this....

If your Hardware is OK and you fit a new hard drive and have a good a disc image made when your system was running fast and sweet then by reimaging you can have your system back up and running again in less time than it takes to walk the dog .

Post back if you need further information.
Regards
paws


  • 0






Similar Topics


Also tagged with one or more of these keywords: boot, black screen, laptop, vista, win7, toshiba logo, toshiba satelite, satelite, p300, toshiba

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP