Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Unsupported Browser. But I DO have IE 11


  • Please log in to reply

#1
jen147

jen147

    Member

  • Member
  • PipPipPip
  • 223 posts

Very frustrated today!  All I wanted to do was change the password on my Apple ID.  So I went to Apple.com to do that.  They asked for my security questions to which I had forgotten my answers because it's been so long since I had been in it.  So I use their support pages navigating to the "if you forgot your security question answers" page... keep in mind that every page so far has displayed perfectly.  It's only when I click their link to "Start your support request online" that I get:

 

Unsupported Browser

We recommend the latest version of Safari, Firefox, Chrome, or Internet Explorer to use our support pages and tools.

 

I did some research online & what I found was to add the website to the Compatibility View Settings box in Tools.  To which I did, Did NOT work.  And all the other pages that I'd visited that did display correctly would not work with apple.com in the Compatibility box.  So I am stuck.  I can only remember IE doing this one other time but I can't remember what website that was.  No other problems besides this.

 

What can I do?


  • 0

Advertisements


#2
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts

Hi,
 
How about using a different browser?
 
Can you visit the following page www.whatsmyuseragent.com using Internet Explorer and post the User Agent String without the IP Address.


  • 0

#3
jen147

jen147

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 223 posts

Hello, thanks for the reply.  I really don't want to use a different browser.  Here is the info you asked for:

 

Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko


  • 0

#4
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts

Hello, thanks for the reply.  I really don't want to use a different browser.  Here is the info you asked for:

 

I understand but it helps for diagnostic purpose.
 

Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko

 

Try to reset Internet Explorer settings


  • 0

#5
jen147

jen147

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 223 posts

Hello, I'm sorry it's taking me so long to get back to this topic.  I currently have other issues that are of more importance than this one.  Have been having issues updating AMD video card driver.  It's been a nightmare.  Plus we are on vacation from school & I'm busy with summer activities.  So once I get that graphics driver updated I'll try to come back to this.  Just didn't want you to think I didn't appreciate your help.


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP