Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

I can't download a driver for my video card.


  • This topic is locked This topic is locked

#16
sigdig

sigdig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts

And PhillPower2, I'm not sure what drivers I am going to save in text format and paste them to my reply, because there is 170 of them


  • 0

Advertisements


#17
sigdig

sigdig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts

 

There was no  irror installing with AT Inc.'s method, but the same as had always happened, happened. It looked like it installed perfectly, but after I restarted the computer, the Device Manager said that there was no driver installed for the device, eventhouugh I just did it. I can neither connect more than one screen to the video card anymore..  http://gyazo.com/f39...24b316a9b988f66

 

Well actually, when I think about it, I can remember some kind of message after I installed it. I will check it out.

Alright, can you answer phil's question and tell us who is the manufacturer of your graphic card ? Also, it looks like you're missing your Monitor drivers. What is your monitor brand and model ?

 

 

I have three monitors, and that thing has always been there, so I don't think thats something wrong.. Oh and as you can see, it isn't under other devices bc it doesn't have a driver... It saiys it's working properly c:

http://gyazo.com/1fc...eb6831a8f984119 <--Screenshot


Edited by sigdig, 11 June 2014 - 11:19 AM.

  • 0

#18
Aura

Aura

    Special Ops

  • Malware Removal
  • 2,563 posts

 

 

There was no  irror installing with AT Inc.'s method, but the same as had always happened, happened. It looked like it installed perfectly, but after I restarted the computer, the Device Manager said that there was no driver installed for the device, eventhouugh I just did it. I can neither connect more than one screen to the video card anymore..  http://gyazo.com/f39...24b316a9b988f66

 

Well actually, when I think about it, I can remember some kind of message after I installed it. I will check it out.

Alright, can you answer phil's question and tell us who is the manufacturer of your graphic card ? Also, it looks like you're missing your Monitor drivers. What is your monitor brand and model ?

 

 

I have three monitors, and that thing has always been there, so I don't think thats something wrong.. Oh and as you can see, it isn't under other devices bc it doesn't have a driver... It saiys it's working properly c:

http://gyazo.com/1fc...eb6831a8f984119 <--Screenshot

 

 

It looks like it's looking on Microsoft Basic Display Driver, which might change once you install your AMD graphic card drivers depending on how the monitor is connected.

Can you tell us what is the manufacturer of your graphic card please ? Sapphire, MSI, etc. ? Me (or phil) will go grab the drivers from their website and link it to you so you can try these ones instead.


  • 0

#19
sigdig

sigdig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts

That is my video card and where I bought it --> https://www.komplett...gb-gddr5/776938

 

Sapphire Radeon HD 7790 1GB GDDR5

Edited by sigdig, 11 June 2014 - 11:30 AM.

  • 0

#20
Aura

Aura

    Special Ops

  • Malware Removal
  • 2,563 posts

 

That is my video card and where I bought it --> https://www.komplett...gb-gddr5/776938

 

Sapphire Radeon HD 7790 1GB GDDR5

 

According to the information you have me, this would be the drivers download page for your graphic card :

 

http://www.sapphiret...006&lid=1&os=12

 

I would download the Catalyst Software Suite (from Apr 25, 2013) and install these drivers.


  • 0

#21
sigdig

sigdig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts

After the installation, this is what I get everytime I try to install the driver: http://gyazo.com/9ec...d4e8e8909f2bdac

 

When I click at view log, a text document appears: http://www.2shared.c...1zz/Report.html


  • 0

#22
Aura

Aura

    Special Ops

  • Malware Removal
  • 2,563 posts

After the installation, this is what I get everytime I try to install the driver: http://gyazo.com/9ec...d4e8e8909f2bdac

 

When I click at view log, a text document appears: http://www.2shared.c...1zz/Report.html

The AMD Display Drivers and HDMI Audio Drivers failed to install.

Can you try this installation in Safe Mode like you did at the start ? It looks like it have more successful results there and hopefully the installation will go through.


  • 0

#23
sigdig

sigdig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts

 

After the installation, this is what I get everytime I try to install the driver: http://gyazo.com/9ec...d4e8e8909f2bdac

 

When I click at view log, a text document appears: http://www.2shared.c...1zz/Report.html

The AMD Display Drivers and HDMI Audio Drivers failed to install.

Can you try this installation in Safe Mode like you did at the start ? It looks like it have more successful results there and hopefully the installation will go through.

 

Alright


  • 0

#24
phillpower2

phillpower2

    Mechanised Mod

  • Moderator
  • 23,096 posts

You should also use DriverView to check for any earlier incorrect drivers that have been installed.


  • 0

#25
sigdig

sigdig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts

 

After the installation, this is what I get everytime I try to install the driver: http://gyazo.com/9ec...d4e8e8909f2bdac

 

When I click at view log, a text document appears: http://www.2shared.c...1zz/Report.html

The AMD Display Drivers and HDMI Audio Drivers failed to install.

Can you try this installation in Safe Mode like you did at the start ? It looks like it have more successful results there and hopefully the installation will go through.

 

I did it, but Im got the same error as last time, when I tried to install from the CD in safe mode... :(                   http://www.2shared.c...X0Ul/image.html


  • 0

Advertisements


#26
sigdig

sigdig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts

You should also use DriverView to check for any earlier incorrect drivers that have been installed.

Can you tell me how to? (I just download DriverView) I'm not sure what drivers I am going to save in text format and paste them to my reply either (as you said earlier.) There is 170 of them


Edited by sigdig, 11 June 2014 - 12:41 PM.

  • 0

#27
Aura

Aura

    Special Ops

  • Malware Removal
  • 2,563 posts

 

You should also use DriverView to check for any earlier incorrect drivers that have been installed.

Can you tell me how to? (I just download DriverView) I'm not sure what drivers I am going to save in text format and paste them to my reply either (as you said earlier.) There is 170 of them

 

 

I can't talk for phill but personally for me, you could still take all the drivers and save them in a text format. I'll just use Ctrl + F to find AMD related drivers and other graphic card manufacturer drivers.


  • 0

#28
phillpower2

phillpower2

    Mechanised Mod

  • Moderator
  • 23,096 posts

You only need to go through the list yourself and check for any earlier drivers that may have been installed, if there is none fine but if there are any copy/paste them into your next reply and AT or myself will take a look at them for you and let you know if they are safe to uninstall.


  • 0

#29
sigdig

sigdig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts

I can't find anyone? Or actually I can see one, but that's a sound driver ---> http://gyazo.com/7ad...0d9ae615a90ad50


  • 0

#30
Aura

Aura

    Special Ops

  • Malware Removal
  • 2,563 posts

I can't find anyone? Or actually I can see one, but that's a sound driver ---> http://gyazo.com/7ad...0d9ae615a90ad50

 

Is there anymore AMD drivers installed or is that the only one ?

In my opinion, this driver was already installed before you created that thread otherwise it would have shown in the Device Manager screenshot that you posted. I'm thinking about making you doing a clean uninstall of Catalysm and it's drivers (via AMD uninstall/cleaning tool) and then restart from scratch.

Can you still give us the content of DriverView (via a textfile that you can upload or copy/paste here) please ?


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP