Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

black screen after installing new 2nd hand video card SAPPHIRE HD 6670

video card black screen

  • Please log in to reply

#1
ronmae

ronmae

    Member

  • Member
  • PipPip
  • 15 posts

I buy a video card SAPPHIRE HD 6670 1GB GDDR5 to other person and he said it's working he used his video card for watching movies in tv using hdmi. but when I installed it to my pc, turn on pc I hear the fan spin in video card but totally black screen even in bios mode I can't enter. I full the volume of the speaker to hear if boot to window screen but I can't hear it boot, it means he can't pass in windows screen....i have no previous video card driver installed because I use integrated graphic processor. I already try many solution like disable integrated graphic processor in bios, uninstall but no luck..it is possible that it have setting in video card when he used it on hdmi or not compatible to my motherboard? but i try my old sapphire 5570 but its's working fine but 6670 have signal and totally black screen ......here is my cpu info

 

 

Name
Intel Core i3-2100 CPU @ 3.10GHz

Threading
1 CPU - 2 Cores - 4 Threads

Frequency
1596.19 MHz (16 * 99.76 MHz)

Architecture
Sandy Bridge (32 nm)

CPUID / Stepping
6.A.7 / 6.2A (D2)

CPU Extensions
MMX, SSE, EM64T, VT-x, AVX

Caches
L1 : 64 KB / L2 : 512 KB / L3 : 3072 KB

Microcode
0x0000029

Max. TDP
65 Watts

Temperature
41°C

Voltage
1.068 Volts

Type
Stock

 
Motherboard
 
Model
Gigabyte H61M-DS2

BIOS
American Megatrends Inc. - 10a - 02/25/2014

CPU Socket
Socket 1155 LGA

North Bridge
Intel Sandy Bridge rev 09

South Bridge
Intel H61 rev B3

 
Memory (RAM)
 
Size
8192 MB

Type
DDR3-1330 - Single Channel

Frequency
665.1 MHz (1:5)

Timings
11-10-10-25

Slot #1 Module
Corsair - 8192 MB (12800)

 
Graphic Card (GPU)
 
GPU Type
Intel® HD Graphics (847 MHz)

VRAM Size
2108 MB
 
Miscellaneous
 
Windows Version
Windows 7 Ultimate Edition 64-bit

Windows Subver
SP1 (Build 7601)

CPU-Z Version
1.71

 

 

 

 

 

here my video card link http://www.sapphiret...?pid=1169&lid=1


  • 0

Advertisements


#2
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,007 posts

to be totally honest with you i'd return it to the seller and get your money back if possible.

 

your 5570 works fine so,

it's not going to be a power problem because both the 5570 and 6670 have the same power requirements.

it's not going to be a driver problem both cards work with the same driver.

it's not going to be a cable or monitor problem because you used the same on both cards.

 

so that really only leaves the problem being a hardware fault on the card itself and why i'd definitely return it, regardless of what the seller says about it working on his system.

 

:popcorn:


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP