Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Com port does not work

  • Please log in to reply




  • Member
  • PipPip
  • 58 posts

Hello, I run Windows 8.1. 

I am trying to use my com port for two weeks now, but no luck.

I tried to connect a device, but it is not communicating.

I tried to make a hyperteminal test, no luck.

Now I am using a software that simulates devices and when I use the com port, 

I get error message that the device is not responding.

In the device manager everything is ok

Thanks in advance

  • 0


Safe Mode

Safe Mode

    New Member

  • Member
  • Pip
  • 6 posts

Hello, My name is Safe Mode and i will be helping you today. 

I can understand this problem is very frustrating and we should have it fixed shortly, 

please tell me more about your com port errors?


Are you getting these errors when trying to use a Bluetooth device?

Are you getting these errors when trying to use a usb?

Are you getting these errors because of your firewall?

If its something else or all of the above comment so i can further assist you

Edited by Safe Mode, 19 February 2015 - 02:13 AM.

  • 0




  • Topic Starter
  • Member
  • PipPip
  • 58 posts

I am trying to connect an old PLC device...Communication failure

The second error is when I tried to run a hyperterminal test...During that attempt I did not get any response.

As the com port does not work at all


The last attempts were during PLC simulation...The last one may occur during false settings (I assume that)...

I tried to make new virtual com port, but no luck during simmulation...


I use AVG Free...I disabled it during every time I tried to communicate with com port


Thanks for your time 

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP