Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Windows 7 Search - Finding things it shouldn't


  • Please log in to reply

#1
redleader74

redleader74

    Member

  • Member
  • PipPipPip
  • 174 posts

I've encountered a strange phenomenon on my Windows 7 computer that I can't figure out.  I'm posting it here because it appears to be Windows 7 related.  I also have Microsoft Outlook 2010 installed.  The problem can be described as follows:

 

I recently used Outlook 2010 to read e-mails off of .pst files that reside on an external USB hard drive.  After finishing I disconnected the external drive.  However, I later went to use the Windows search feature (i.e., the search window that you access from the Start button) to look up some unrelated files (word documents, pdf's, etc.), and I see all the e-mails I've read off of that external drive show up in the search results (those that were related to the search terms I was entering).  Of course, I can't open them (because the physical e-mail file does not exist on the local machine), but I can see the title and preview of e-mail. 

 

How is this possible?  Did Windows 7 make a "temp" copy of those e-mails somewhere on the local machine? If so, where is it?  I've already used CC cleaner to delete all temp files but these e-mails keep showing up in the search return.  This is a bit disconcerting because I don't want those e-mails nor any trace of those e-mails to appear on the local machine.  See attached graphic for what I'm talking about.

 

Any help is much appreciated.  Thanks!

Attached Thumbnails

  • Doc1.jpg

  • 0

Advertisements


#2
Crowbar

Crowbar

    Teacher

  • GeekU Moderator
  • 4,769 posts

Hi redleader74,

You can stop Windows from indexing your Outlook emails in the Indexing Options.

 

Click on Start then type Indexing Options and press enter

From there click on Modify and that will open up the Indexed Locations box

 

In that box you can uncheck Outlook, then click Ok and then finally click on Close.

 

I think you have to reboot, but it probably wouldn't hurt to do so.

 

 


  • 0

#3
redleader74

redleader74

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 174 posts

Thanks Crowbar,

 

Is that to say that whenever Outlook (or Windows) "indexes" something, be it files, e-mails, etc., that it stores some part of it (perhaps not the entire file) on the local machine?

 

Thanks.


  • 0

#4
Crowbar

Crowbar

    Teacher

  • GeekU Moderator
  • 4,769 posts

Yes, I believe it's database sort of.

Maybe cached is a better term.  I am not sure exactly how the mechanism works, but I do know how to stop the indexing :)


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP