Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Printer will print connected to USB but not network wired connection

hp laserjet pro pcl xl error

  • Please log in to reply

Gee Buttersnaps

Gee Buttersnaps

    New Member

  • Member
  • Pip
  • 1 posts

Ok so I had an HP LaserJet 4000n.  A relic, I know.  But it was working...  I was primarily using it connected via wired network and printing from a Win 8.1 64bit PC.  Friday it worked fine.  Monday morning (today) everything I printed gave me a PCL XL ERROR  and the specific error code varied each time.  Sometimes it was a internetalError, missingdata, illegaltag


Always something like that. 


I search the HP and Windows support centers and find no real help.  I realize that HP doesn't carry a driver for that printer with win 8.1x64 so I get the universal printer driver... no luck.


So I finally get frustrated after having tried the PCL 6 driver, PCL 5, PS and having no luck, so I decide that maybe some update has caused it to stop supporting that driver.  So I go out and get a new printer (needed one anyway, the 4000n was getting a bit cranky).  I get an HP LaserJet Pro 400 m401dne.  Install it with the network.  same problem... exact same freaking problem...


finally in a last ditch effort I install the printer to the PC via the USB connection.  When printing from there it works great.  No errors, no problems. 


I can make do with it being a USB printer, no problem.  We really only use it from one computer anyway, but does anyone have a clue why this would be?


I've rebooted my router, switched ports the ethernet coord was plugged in, changed coords... no luck...



Edited by Gee Buttersnaps, 23 March 2015 - 04:48 PM.

  • 0




    GeekU Junior

  • GeekU Junior
  • 558 posts

Can you ping your printer?

Also suggest you set the printer to a static ip outside the routers dhcp pool, and make sure the printer is on the same subnet as your network. Check your printer is set to use your routers gateway address. If all of those are correct it should show some form of life.

Edited by nordvark, 24 March 2015 - 08:17 PM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP