Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Chrome bypassing default DNS

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 9 posts
I use a VPN tunnel provided by my ISP that I trust (for the time being), secured from DSN leaks by dsnfix. It seems to work nicely with Firefox according to the GRC test. Chrome, however, totally bypasses my ISP:s servers and connects to some pretty mediocre ones. I'm not very familiar with Chrome (at the moment the Comodo veriety) so how do I stop this?
  • 0




    GeekU Junior

  • GeekU Junior
  • 633 posts

Hello emmpe,

Sorry for the delayed response in replying to your issue.  I'm not certain what the problem is, but I will be happy to get started in troubleshooting this issue.

Chrome uses DNS caching to facilitate fast loading of sites by mapping the IP addresses from cache when the same domain is opened repeatedly. If the IP address of the site is changed then the DNS caching of Chrome may cause delay in loading the site due to difference in IPs.

  • Go to the URL “chrome://net-internals/#dns” in your Chrome browser. 
  • Click “Clear host cache” button in “Host resolver cache” section or select “Clear cache” option from the drop-down.

Clear DNS Cache in Chrome

You can also try disabling “Built-in Asynchronous DNS” flag in Chrome by following the below instructions.

  • Go to URL “chrome://flags/”.
  • Press Ctrl+F in Windows or Command+F in Mac and search for “asynchronous”.

Disabling Flag in Google Chrome

  • Select “Disable” from drop-down.
  • Click on “Relaunch Now” button for your changes to take effect.

    Please let us know if this helped you or not.  =)

Edited by Fusionbomb, 30 March 2015 - 12:20 PM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP