Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Firefox Troubles

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 2 posts
Hi, I am new to the forum and I've tried to read the appropriate posts about my problems, but I don't see anything parallel. I have a newly set-up D-link wireless DSL connection (card for laptop and router on my PC) and recently I have been having problems with FF on my laptop.

I can connect to my network, start FF, use it for a while no problem. But after a while, when I click on a link it starts loading (the dots in the upper right start, but only the first three) and then says done without loading anything. I can sometimes click multiple times on the link and it will load. Then, it won't load at all even with multiple clicks. I have run adaware, etc and nothing shows up.

I recently installed the most recent version of FF and SP2 on my laptop. I think the problem started after these two additions. It wasn't always doing this -- I used the wireless with FF for about four weeks without issue.

Any help is appreciated.

I have a Hijack This log, but I'll wait to post it. Thanks.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP