Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works


  • Please log in to reply



    New Member

  • Member
  • Pip
  • 3 posts
hi, iv just formatted my drive, everything seems fine, but i attached my external hard drive to the usb port and well it recognises it but when i go to my computer nothing is there, i.e. the hard drive (h:) is not there i can only see the usual, c, d: and e:

i tried to download drivers for lacie from their website and also any other universal usb hub driver for windows 98, but no luck. i ran aida32 and got the following report, which i have attached.

pls heelp!!

thanks a bunch!

p.s. iv added a quick report rather than a full one, becuase everytime i attempt a full report via the wizard or aida32 it goes to a blue error screen and it terminates! :S

Attached Files

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP