Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Graphics card or monitor?

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
So this is driving me batty.

I've got a laptop (Dell Latitude E5440) - only a couple months old - and a brand new monitor (Dell P2214H) which was supposed to replace a dying monitor (AOC something) due to numerous artifacts showing up on the external monitor including:

- Colorful snow/dots/static
- Horizontal lines alone, then eventually bisected by vertical lines creating an eyesore and mess of static (but the display was still showing open documents, email, etc. underneath that)
- Now the display is intermittent with the monitor going into sleep mode when it believes it has no signal
- When the monitor does wake up/receive a signal intermittenly, the I get a party of a display with the above mentioned snow/static/horizontal/vertical lines

I'm fairly certain the issue is neither the cable (tried VGA and DisplayPort) nor the monitors (Dell and AOC) nor docking station (plugged the VGA directly into the laptop and docking station; plugged the DisplayPort into the docking station/laptip does not have DisplayPort port). I've extended the display and duplicated the display - still intermittent. In addition, I now have a small rectangle that sits at the forefront of my desktop before every window or application on my main display (laptop). I can capture screenshots of the rectangle but not the snow/static/lines. I have more than enough RAM and processing power for the system - the external display/laptop combo was working fine for months before the external display started having issues.

I've tried the following:

- Changed resolutions
- Updated drivers
- Rolled back drivers
- Updated Windows/rebooted
- Ran the dxdiag tool for kicks
- Tried a memory test with Windows Memory Diagnostic Tool to no result

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP