Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

PCI express network card "not enough free resources"


  • Please log in to reply

#1
milesjohnson

milesjohnson

    Member

  • Member
  • PipPip
  • 14 posts

Hey all, looking for some help as I can't seem to figure out this issue myself.

 

So I recently upgraded a few parts of my computer, mainly the video card, and adding a new network card for WiFi (was using a USB stick before). Here's my old specs:

 

OS: Windows 7 Professional 64-bit SP1

Mobo: EVGA EVGA P55 SLI E655 (CPU 1)

CPU: Intel Core i7 CPU 870 @ 2.93GHz (Socket 1156)

RAM: 12.0GB Dual-Channel DDR3 @ 533MHz (7-7-7-20)

Video: NVIDIA GeForce GTX 460

Drives: 120GB SSD (primary, C:), 1TB HDD (secondary, E:). 3TB HDD (media, X:)

PSU: CORSAIR TX Series CMPSU-650TX 650W ATX12V

Network: USB stick that provides WiFi

 

And the new parts/replacements:

 

Video: 3071MB NVIDIA GeForce GTX 780 Ti (EVGA)

PSU: EVGA SuperNOVA 750 G2 220-G2-0750-XR 750W ATX12V

Network: TP-LINK TL-WDN4800 Dual Band Wireless N900 PCI Express Adapter

 

I've also updated the BIOS and all drivers during this process.

 

The issue I'm having is on the initial boot of my computer (the first time I turn it on each day, or when there's a huge timeframe between turn boots), my network card does not work. If I check the device manager, it says the card is disabled with the following error:

 

"This device cannot find enough free resources that it can use. (Code 12) If you want to use this device, you will need to disable one of the other devices on this system."

 

If I restart my computer, the card works, everytime 100% of the time. It's only that initial boot that seems to cause issues.

 

I've googled that error and tried a few approaches to fixing it, they are:

 

* Unchecking "Allow the computer to turn off this device to save power". Problem still persists.

* Check the IRQ codes in BIOS. Everything seems correct. However, when the card is working, its IRQ is set to "0xFFFFFFFE (-2)", while all other IRQs start with "0x000000##". I'm not sure if this is normal or not. I've attached a screenshot of all IRQ settings.

 

I've talked to my friend about this, and he seems to believe that the video card is too powerful for my motherboard and it's sucking up all availabe resources. I'm not sure how accurate that is but any information would be helpful!

Attached Thumbnails

  • irq.jpg

  • 0

Advertisements


#2
phillpower2

phillpower2

    Mechanised Mod

  • Moderator
  • 23,905 posts

:welcome:   milesjohnson,

 

Can you check the boot sequence in the BIOS and post the details here for us please.

 

Download then run Speccy (free) and post the resultant url for us, details here,  this will provide us with information about your computer hardware + any software that you have installed that may explain the present issue/s. 


  • 0

#3
milesjohnson

milesjohnson

    Member

  • Topic Starter
  • Member
  • PipPip
  • 14 posts

Sure, here's some info on my BIOS settings.

 

IDE Configuration

Primary = SSD

Secondary = 3TB HD

Secondary Slave = Optical Drive (This seems wrong?)

Third = 1TB HD (This should probably be secondary)

 

Quick Boot = Enabled

1st Boot Device = SSD

2nd Boot Device = Optical Drive

 

And here's the Speccy snapshot: http://speccy.pirifo...UN50j27VGywucMy


Edited by milesjohnson, 14 June 2015 - 02:18 PM.

  • 0

#4
phillpower2

phillpower2

    Mechanised Mod

  • Moderator
  • 23,905 posts

Apologies for the delay getting back to you, been inundated with work here  :(

 

Looking at the additional information that you have provided it is possible that the BIOS settings have somehow been changed from AHCI to IDE, to check this, your MB should have a clear CMOS button at the rear of the case but I would suggest that you try restoring the MBs factory default settings within the BIOS itself, you most likely know "how to" but for others that may read your thread;

 

To enter the BIOS Setup;

 

To verify/change BIOS settings. 1. Power on the computer. 2. Press the Del key when the following message briefly displays at the bottom of the screen during the Power On Self Test (POST). Press F2 to Load Defaults, DEL to enter Setup. Pressing Del takes you to the AMI BIOS CMOS Setup Utility

 

Once the defaults have been restored, shut down the computer, disconnect the power cord from the wall socket, press the computer/case power on button for 20 to 30 seconds to expel any residual charge in the system, reconnect the power lead to the wall socket, restart the computer to see if there is any change then post back with an update for us.


  • 0

#5
milesjohnson

milesjohnson

    Member

  • Topic Starter
  • Member
  • PipPip
  • 14 posts

I reset to defaults but I noticed that IDE and ACHI are both enabled in defaults. Should I choose one over the other?

 

Both my HDDs are Western Digital while my SSD is Crucial. I know that WD is behind the IDE spec, so perhaps that might be better?

 

If I disable IDE and strictly use ACHI, would there be any issues with my current drives?


  • 0

#6
milesjohnson

milesjohnson

    Member

  • Topic Starter
  • Member
  • PipPip
  • 14 posts

Just saw this:

 

"AHCI is supported by all versions of Windows Vista and newer, Linux and Mac OS. However, Windows does not configure itself to load the AHCI driver upon boot if the SATA-drive controller was not in AHCI mode at the time of installation. So the PC will not boot up if the SATA controller is later switched to AHCI mode. The drive controller should be changed to AHCI or RAID before installing the operating system."

 

Perhaps this is something I can do when Windows 10 comes out next month.


  • 0

#7
phillpower2

phillpower2

    Mechanised Mod

  • Moderator
  • 23,905 posts
I reset to defaults but I noticed that IDE and ACHI are both enabled in defaults. Should I choose one over the other?

 

 

Try disabling the IDE option (it can always be re-enabled if nothing changes) reason being that you never had this problem before with the present installation of Windows 7 and your SSD has the OS on it and so should be the primary boot device (SATA).

 

"AHCI is supported by all versions of Windows Vista and newer, Linux and Mac OS. However, Windows does not configure itself to load the AHCI driver upon boot if the SATA-drive controller was not in AHCI mode at the time of installation. So the PC will not boot up if the SATA controller is later switched to AHCI mode. The drive controller should be changed to AHCI or RAID before installing the operating system."

 

 
Perhaps this is something I can do when Windows 10 comes out next month.

 

 

And from your OP;
 
If I restart my computer, the card works, everytime 100% of the time. It's only that initial boot that seems to cause issues.

 

 

Please note that the MB and all other important drivers such as for your wireless card should also be on the SSD** and not on either of the HDDs, this because Windows will find and install any compatible drivers once Windows itself has loaded, if the drivers for the wireless card are on one of the HDDs, what will be happening, once Windows has booted up ok it will find the drivers for the wireless card, the drivers will remain loaded while Windows is active but will not be automatically installed once the computer has been fully shut down

 

** You are getting low on free storage space on the SSD, storage devices that contain an OS such as Windows 7, 8 or 8.1 etc should have a minimum of 25% of the drives overall storage capacity available as free storage space at all times so as to avoid data corruption and/or possible mechanical failure of the drive.

 

Tip

If you have something to add while waiting for a reply use the edit tab – bottom right of the dialogue input box and this will ensure that no information that you provide is overlooked (this can happen if your topic has more than one page)


  • 0

#8
milesjohnson

milesjohnson

    Member

  • Topic Starter
  • Member
  • PipPip
  • 14 posts

Tried switching to AHCI and it blue screened and would not boot up. Had to switch back to IDE. This looks like something I will have to wait to do until I reformat the drives for Windows 10.

 

Any other ideas?


  • 0

#9
phillpower2

phillpower2

    Mechanised Mod

  • Moderator
  • 23,905 posts

Did you try starting in Safe Mode when the AHCI option was enabled.

 

Did the new wireless card come with a drivers disk, if yes, are the drivers installed on the SSD/C: drive so that Windows has easy access to them were the drivers for the previous device uninstalled.

 

Due to the card working on a restart but not after a complete shutdown of the computer I suspect that it is a software/driver as opposed to a hardware issue.


  • 0

#10
milesjohnson

milesjohnson

    Member

  • Topic Starter
  • Member
  • PipPip
  • 14 posts

Will try AHCI in a bit, but I checked the driver locations, and they seem fine, both in C:\Windows\system32\drivers


  • 0

Advertisements


#11
phillpower2

phillpower2

    Mechanised Mod

  • Moderator
  • 23,905 posts

Update acknowledged  :thumbsup:

 

Not being pedantic but were the drivers listed as being for a TP-LINK TL-WDN4800 Dual Band Wireless N900 PCI Express Adapter and were the drivers for the previous device uninstalled.


  • 0

#12
milesjohnson

milesjohnson

    Member

  • Topic Starter
  • Member
  • PipPip
  • 14 posts

Went through and deleted all old drivers, still the same issue.

 

Also tried setting to AHCI again, and then attempting to boot into safe mode. I had no safe mode option on startup, only "Start Windows 7", or repair installation, both of which goes to blue screen. Had to switch back to IDE.


  • 0

#13
phillpower2

phillpower2

    Mechanised Mod

  • Moderator
  • 23,905 posts

Can you download/install DriverView and copy/paste the results into your next reply for us please, see here


  • 0

#14
milesjohnson

milesjohnson

    Member

  • Topic Starter
  • Member
  • PipPip
  • 14 posts

Here you are.

Attached Files


  • 0

#15
phillpower2

phillpower2

    Mechanised Mod

  • Moderator
  • 23,905 posts

There are wireless drivers installed but none for the TP Link wireless card that you have.

 

Create a new folder on the desktop, name it TP Link.

Download and save to the above folder the drivers from here

Create a new restore point.

Uninstall all of the present wireless device drivers.

Restart the computer in Safe Mode.

Install the drivers that you saved to the TP Link folder.

Restart the computer as you normally would and test.


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP