Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

ASUS K50C, can't boot

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts



I've got 4 years old ASUS K50C laptop. Everything was working fine until recently when I shut it down. Now, when I press power button it usually doesn't respond at all, but like once per 15-20 tries it does - fan starts for half a second and then it stops, other than that all I can see responding is power supply LED. I open it and disconnected all peripherals, unattached motherboard from the rest of it and tried to boot it, but nothing's changed. I unmounted RAM and got it running for a second like before and there wasn't even sound signal that RAM is missing. 


I tried unplugging battery and power supply, then holding power button down for minute and it didn't make a difference. Is there anything else I can try, or am I right assuming that motherboard/CPU is fried?


Regards, Rafal Telaczynski.

  • 0


Natalie Green

Natalie Green


  • Member
  • PipPip
  • 74 posts

Your motherboard is done with it's life  :laughing:

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP