Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Chrome lagging, adds and more


  • Please log in to reply

#1
CrazyBat

CrazyBat

    Member

  • Member
  • PipPip
  • 10 posts

Hi guys, 

so I have a little problem that is confusing me. I never had to use add blockers, my Chrome would run smooth even without them but today I had to install add blocker because my Chrome started lagging and lagging more and more.

 

This was my last attempt to reduce that lagg and only when I installed uBlock did the lag stop.

 

So please if someone has any idea, what exactly made my Chrome behave like that all of a sudden because as I said, before adds were no problem.

 

 

Not a big issue, but Id appreciate any info to what may be the problem here.

 

Regards

Bat


  • 0

Advertisements


#2
Natalie Green

Natalie Green

    Member

  • Member
  • PipPip
  • 74 posts

It's beacuse of the ad .

It may be possible that your internet speed is getting slow.

Please be specific in stating the problem.


  • 0

#3
CrazyBat

CrazyBat

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts

Specific; My Chrome wasnt laging. It run normally. I didnt download anything and my Notebook is clean from malware. But my Chrome started lagging few days ago. Tabs would load and load to open the full page. 

I cleared history and cache, still the same. I used Software removal tool which restored my Chrome to default. Chrome still lagging. Then I installed add blocker and all of the sudden Chrome works great.

 

So I am wondering why exactly did this happen because before I had no problems with adds and I never had to instal adblocker. Is my flash problem, or graphic card?


Edited by CrazyBat, 01 July 2015 - 06:55 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP