Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't boot up computer when external HD is plugged in

Cantbootup computer external HD Harddrive plug plugged NTLDR Missing

Best Answer dsenette , 12 November 2015 - 07:54 AM

sounds like the computer is set to boot from USB media higher in the boot order than the onboard hard drive. boot into bios or uefi (whatever you have) and either lower the order of the USB hard dr... Go to the full post »


  • Please log in to reply

#1
xxKiko

xxKiko

    New Member

  • Member
  • Pip
  • 3 posts
Here's the story: I turned on my computer one day to play a game on Steam. When I opened the Steam application up, I noticed my game library wasn't showing up. A minute later, I figured out why. My external HD has been set to G: drive instead of its normal D: drive. Steam was set to look for my games in the D: drive. I don't know why my external HD changed drives. It just randomly did.
Well, I wasn't thinking straight that day. Instead of changing the directory in the Steam settings, I stupidly tried to change my external HD's drive letter back to D.

I was successful at first. It changed back to D: and Steam recognized my games. But... then the next time I boot up my computer with my external HD plugged already plugged in (as always), and it keeps saying "NTLDR file is missing. Press ctrl-alt-del to restart." I did what I could, but it still won't stop.

So, now, every time I want to boot up my computer, I have to make sure my external HD isn't plugged in before pushing the power button which is annoying. I sometimes forget to unplug it after turning my computer off. I have to turn the computer back off to unplug and to proceed to my login screen.
Oh and it set itself back to G: and I did change Steam's directory path to G:.

What can I do to get it to stop saying the NTLDR is missing and I can stop having to unplug my external HD before turning my computer on?

I have Windows 7: Home Premium.

Thank you in advance!
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
✓  Best Answer

sounds like the computer is set to boot from USB media higher in the boot order than the onboard hard drive. boot into bios or uefi (whatever you have) and either lower the order of the USB hard drive in the boot order, or if you can, disable USB boot all together.


  • 0

#3
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,575 posts

Reboot your computer and see if there is a drive D assigned. I suspect that your assigning the external drive to D is causing a conflict, so you would need to reboot and then change the drive to another letter. I tend to use a letter far down so that there would never be a conflct.


  • 0

#4
xxKiko

xxKiko

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Thank you, Dsenette!!! You were right. I was able to figure out how to get the computer stop trying to boot up from my external HD! I really appreciate it!
  • 0






Similar Topics


Also tagged with one or more of these keywords: Cantbootup, computer, external, HD, Harddrive, plug, plugged, NTLDR, Missing

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP