Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Need help reinstalling Lexmark 2300 series printer


  • Please log in to reply

#1
Cabranth

Cabranth

    Member

  • Member
  • PipPipPip
  • 143 posts

Hi all,

 

Recently I had to do a repair install of my Win7x64 OS. Part of that uninstalled my Lexmark 2300 series printer (manual here if you are interested). When I tried installing from the CD I keep getting that processor incompatibility message. I've googled the problem and one tip I found is trying all the compatability settings on the Setup.exe . I tried every one, and got the same message.

 

Then I found what is supposed to be a Win7x64 installer here. It is named "Z2300", not "2300 series", but I thought it might be the same thing. When I run the installer, I get to the part where it says connect your printer USB, and it never recognizes the USB cable. The "Continue" button on the bottom just stays greyed-out. I've waited 10 minutes just in case it's laggy, I've tried connecting to every empty USB port on my PC both front and back, but it never recognizes it. I know my USB ports are working, because I have several in use right now, plus I use a stick on the front ports about every week or so.

 

I've had this printer working with my PC since I put it together in January of 2012, so I know I figured out how to get it installed previously, I just can't remember what it was that I did. For all I know there might be an archived thread somewhere here from the last time, but I didn't find anything with the Search.

 

I'd greatly appreciate any help figuring this out again.


  • 0

Advertisements


#2
paws

paws

    WTT Tech Teacher

  • Tech Academy Moderator
  • 523 posts

Hi, sorry to hear of the printer issue,

Just so its clear in my mind is your Printer a Lexmark z2300

or a Lexmark 2300 series ( with perhaps a number like Z2320 or similar?

 

1 It would be worthwhile, uninstalling the printer by downloading Revo uninstaller available from here:

 

http://www.revounins...e_download.html

 

2 scroll down towards the bottom of the page for the freeware version, install it and then use it to uninstall the Lexmark printer software.

Accept the defaults and hopefully Revo will find all the stray left over entries that often get left behind by a "normal" uninstall

 

3 The next step is VERY important, switch off the printer and disconnect its power cable AND USB cable from the computer.

 

4 Now close down your computer (a full shutdown not a hibernate sleep) and disconnect its power cable from the wall socket and then from the computer.

 

5 Wait 5 minutes with everything powered down:

 

6 Reconnect the power cable to the computer and then to the wall socket DO NOT connect the USB printer cable at this stage

 

7  Power on your computer (still with printer cable disconnected)

 

8 install the printer software (I think you have the download site, but I'll link to it below:)

 

http://support.lexma...serlocale=EN_UK

 

9 Install the software and follow its on screen directions (ONLY connect the USB cable when instructed to do so) and make sure that at that point the printer is already powered on.

 

This should do the trick for you, if it doesn't then it generally means that there are more deep seated problems with your set up or... you did it wrong!)

 

Post back and let us know how you get on.

Regards

paws


  • 0

#3
Cabranth

Cabranth

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 143 posts

Hi paws,

 

I'm very sorry it took me so long to get back to you. I had some family stuff that needed my undivided attention the last few days.

 

In answer to your question, my printer is a 2300 Series, not a z2300. After I actually looked at my printer again more closely, I found the specific version # of the 2300 series I have (it's a X2350) and was able to track down a 64 bit Windows installer for it.

 

I will go ahead and follow your instructions for doing a completely clean uninstall and try the X2350 64-bit installer, then I'll let you know if I got it back up and running. That was probably the holdup all along and I just didn't bother looking closely at my machine. It doesn't help that my machine says X2350 and my manual and install disc both say 2300 Series.


  • 0

#4
paws

paws

    WTT Tech Teacher

  • Tech Academy Moderator
  • 523 posts

:thumbsup:


  • 0

#5
Cabranth

Cabranth

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 143 posts

Hi again paws,

 

Got it all taken care of and set back up. The Lexmark site had a Vista 64 bit installer package for the X2350 still available that worked just fine.

 

Appreciate the help once again. Sorry to take up time with something I should've figured out myself if I'd just looked a little closer. :oops:

 

You can close this anytime.


  • 0

#6
paws

paws

    WTT Tech Teacher

  • Tech Academy Moderator
  • 523 posts

 That's good to hear
Glad you got it fixed

:thumbsup:

 

We don't close topics in this particular forum.... as sometimes folks with a similar problem will come across the topic and the solution, perhaps a year or so later via a search engine..... if that happens they will bless the name of  Cabranth when they come across the solution!

Regards

paws


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP