Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

No display after deletion of BIOS

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts

I have an extra PC. Its old but I wanted to upgrade it. I tried to update the BIOS since it will enable the motherboard to support some am3 socket processors. But I realized that my method was wrong. I updated the BIOS through asus update utility in windows. It erased the current BIOS but was unable to install the new one. So I was left without a BIOS.


The motherboard is Asus M3A78-CM. 


Knowing that it supports crash free BIOS 3, i turned the PC off then power it on again. The fans would turn, there is no beeping sound, there is no display, the lights on the keyboard (num, caps, scroll) does not work but the mouse has its lights on. 


I am using a PS/2 keyboard and a USB mouse. I removed every peripheral including the graphics card. I removed the rest of the RAM sticks leaving just a singe 2gb stick.


I tried to plug a USB flash drive formatted to FAT and FAT32 with the latest ROM. Nothing happens, the flash drive doesn't even light up. I already renamed the rom to M3A78CM.ROM but still nothing happens.


Can anyone please help? It would mean a lot. 

  • 0





  • Member
  • PipPipPip
  • 985 posts

what bios version are you trying to flash? and what was the original bios version? is the file zipped or are have you got the unzipped files on the flash drive?


first i'd remove all power and the motherboard battery, then replace battery, reconnect power lead, insert usb stick with bios on and then power on the pc if no luck with the files on a usb stick, i'd repeat process but this time using a cd with the bios file instead.


see if this works for you.


Power off the pc for a few minutes (unplug it from the wall and press the on button to make sure it is completely powered down) and then power it back up, press CTRL and HOME right after you power it on (you may have to press CTRL & Home several times until you get the timing just right). If all goes well you should hear a series of beeps coming from the pc and it will start searching the floppy / cd for a bios image, You will also see an onscreen message telling you that the bios recovery is searching for a rom file.



don't forget your monitor needs to be connected to the motherboard vga port and not the dvi port or a graphics card.




Edited by terry1966, 07 December 2015 - 08:37 PM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP