Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Windows don't like my sata

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Wondering if anyone can help this has had me puzzled for a while. I got a new maxtor dimondmax sata 250gb drive to add for extra storage replacing 2 60gb maxtor ide's which had given up after a long haul, connected it all up got into windows formatted the drive and copied everything i needed onto it. Everything was working fine for a while then windows stopped loading. Ran through usual problems disabling this and that, narrowed it down to usb2 and sata. Now only the sata causes problems and usb is fine. If sata is enabled in bios, windows won't boot into safe mode, it will boot normally but becomes so sluggish it is nearly ususable. I have installed latest bios on mobo, latest updates for xp, latest sata drivers, cleaned out viruses spy/ad ware. everything works fine when drive not connected, but horrible if it is. Using windows xp pro sp2. Any help would be appriciated.

Abit AN7 with amd XP3200
1gb ddr3200
Radeon x800
60gb maxtor ide
250gb maxtor sata

Edited by eusebioechevarria, 15 June 2005 - 05:45 AM.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP