Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Unable to set Location

- - - - -

  • Please log in to reply

#1
cigos

cigos

    Member

  • Member
  • PipPipPip
  • 127 posts

In Windows 10 on my desktop the control for 'Location' is greyed out, so I cannot activate it.

 

I have looked at various solutions and thought I had cracked it by changing to a local account,

as Administrator.  However when I went to Settings I found the control still greyed out!

 

Any suggestions, please?

 

Kind regards, Cigos


  • 0

Advertisements


#2
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

Hi cigos,

 

If the icon is greyed out it sounds like location services has been disabled and not just turned off, try the below instructions and see what happens.

 

  • Click the Start button in the bottom left corner.
  • Click Settings.
  • Type in Location privacy settings into the search bar located in the top right corner and click Location privacy settings.
  • Click the Change button and change it to On.
  • Click anywhere to dismiss the window when done.

Location services have now been enabled, you should be able to toggle it off and on now from the action center.


  • 0

#3
cigos

cigos

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 127 posts

Thanks Freshman,

 

Tried it but it remains stubbornly greyed out!

 

Cigos


  • 0

#4
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

When you tried to turn location services on did you manage to actually turn it on it should say Location for this device is on above the change button, or does the change button not work and nothing comes up / happens when clicked.

 
I would like to get you to check and see if the Gelocation Service is started.

  • Right click the Start button located in the bottom left corner.
  • Click Run.
  • Type in services.msc and press Enter.
  • A services window will open.
  • Locate the service called Gelocation Service.
  • Right click Geolocation Service and click Properties.
  • In the startup type box change it to Automatic then click Apply located in the bottom right then click Ok.

  • 0

#5
cigos

cigos

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 127 posts

Hello Freshers,

                          Still no luck!  My settings show a message saying some of my settings are controlled by my organisation.

 

However, I am the sole administrator of the machine so I think I must have followed some advice somewhere to turn off

location and Cortana; either as general or security policy.  I probably needed them off temporarily and now have this

dilemma!

 

Do you think you could help me in that respect?   I have applied the Geolocation Service.

 

Grateful for your efforts,   Kind regards, Cigos


  • 0

#6
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

When you tried to turn location services on did you manage to actually turn it on it should say Location for this device is on above the change button, or does the change button not work and nothing comes up / happens when clicked.

 
It seems you missed my question could you read my above question located in the quote.
 
Also does it say up the top Some settings are managed by your organization.
 

I have applied the Geolocation Service.

 
Did you get any errors while starting Geolocation service or is it now started.
 
 
I will do some more research regarding what you said.
 
 
 
EDIT:


I will get you to check some group policies


Check Computer Configuration policies

  • Right click the Start button located in the bottom left.
  • Click Run.
  • Type in gpedit.msc and press Enter.
  • Click Computer Configuration located on the right side.
  • Click Administrative Templates.
  • Click Windows Components.
  • Look for Location and Sensors and double click it.
  • Make sure everything is set to Not configured. If it has been changed click the one that has been changed, double click policy settings to the left, tick the Not configured box then click Apply then Ok.

 

Check User Configuration policies

  • Right click the Start button located in the bottom left.
  • Click Run.
  • Type in gpedit.msc and press Enter.
  • Click User Configuration located on the right side.
  • Click Administrative Templates.
  • Click Windows Components.
  • Look for Location and Sensors and double click it.
  • Make sure everything is set to Not configured. If it has been changed click the one that has been changed, double click policy settings to the left, tick the Not configured box then click Apply then Ok.

Edited by Nyser, 14 January 2016 - 03:21 AM.

  • 0

#7
cigos

cigos

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 127 posts

I could not get past the first hurdle, I'm afraid!  See attached, please.

 

Regards Cigoslocality solution.PNG


  • 0

#8
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

Sorry about that I didn't know that gpedit isn't on all versions of Windows, Below are the steps to do it in registry instead of group policy editor.

 

Step 1

  • Right click the Start button located in the bottom left corner.
  • Click Run.
  • Type in regedit and press Enter and click Yes to UAC popup.
  • Double click HKEY_LOCAL_MACHINE
  • Double click SOFTWARE.
  • Double click Policies.
  • Double click Microsoft.
  • Double click Windows.
  • Click LocationAndSensors.
  • Right click DisableLocation located on the right side and click modify.., make sure Value data is set to 0.

 

Step 2

  • Right click the Start button located in the bottom left corner.
  • Click Run.
  • Type in regedit and press Enter and click Yes to UAC popup.
  • Double click HKEY_CURRENT_USER.
  • Double click SOFTWARE.
  • Double click Policies.
  • Double click Microsoft.
  • Double click Windows.
  • Click LocationAndSensorsNOTE: If the LocationAndSensors folder isn't there it normally means that it is either disabled or hasn't been enabled before so don't worry about the last part of this step.
  • Right click DisableLocation located on the right side and click modify.., make sure Value data is set to 0.

 

Step 3

  • Restart your computer and try turn on location, follow post #2 if instructions are needed.

  • 0

#9
cigos

cigos

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 127 posts

Esteemed Freshman,

                                    That was spot on!   Location ON again.  Thank you very much.

 

Incidentally, Cortana is greyed out, similarly saying 'By Company policy'.  Although I don't particularly

want Cortana at present; would something similar apply to that in the Registry?

 

Kind regards, Cigos


  • 0

#10
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

Glad I could finally help with enabling locations, enabling Cortana should be quite similar.

 

 

Enable Cortana

  • Right click the Start button located in the bottom left corner.
  • Click Run.
  • Type in regedit and press Enter and click Yes to UAC popup.
  • Double click HKEY_LOCAL_MACHINE
  • Double click SOFTWARE.
  • Double click Policies.
  • Double click Microsoft.
  • Double click Windows.
  • Click Windows Search.
  • Right click AllowCortana located on the right side and click modify.., make sure Value data is set to 0.
  • Restart computer.

 


  • 0

Advertisements


#11
cigos

cigos

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 127 posts

I only wish I were younger and could assimilate the kind of information you possess!

 

This time when I reached the Windows Search I found no reference to Cortana thus

I was unable to undo my mistakes of the past.

 

I have attached a clip of the registry to illustrate the position.

 

Best wishes, Cigos

Attached Thumbnails

  • Missing Cortana.PNG

  • 0

#12
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

I would like to confirm a couple of things with you.

  • Is your Windows 10 activated?
  • Have you had Cortana working on this computer before?

Basically I'm trying to confirm if it has been disabled or just not set up correctly.

 

 

I will get you to try what you did last post except this time we will make the value, it probably wont work but its worth a try.

  • Right click the Start button located in the bottom left corner.
  • Click Run.
  • Type in regedit and press Enter and click Yes to UAC popup.
  • Double click HKEY_LOCAL_MACHINE
  • Double click SOFTWARE.
  • Double click Policies.
  • Double click Microsoft.
  • Double click Windows.
  • Click Windows Search.
  • Right click anywhere on the white area located on the right side and hover your mouse over New then click DWORD (32-bit) Value.
  • Change the name from New Value #1 to AllowCortana.
  • Right click AllowCortana and click modify.., Set the Value data to 1 then click Ok.
  • Restart your computer.

  • 0

#13
cigos

cigos

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 127 posts

I'm afraid this attempt did not work; as you suspected.

 

Regarding activation, although an 'Insider' on one laptop, this desktop was

a straight upgrade from Windows 8.1.  I am pretty sure Cortana worked

originally.  I am inclined to experiment and do not always record what I

have done, unfortunately.

 

Thank you for your continued efforts.

 

Regards, Cigos

 

I have attached a clip of the Cortana setting.

Attached Thumbnails

  • Cortana disabled.PNG

Edited by cigos, 21 January 2016 - 11:12 AM.

  • 0

#14
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

I think I overlooked something in your earlier screenshot, try change this value and fingers crossed that it works.

  • Right click the Start button located in the bottom left corner.
  • Click Run.
  • Type in regedit and press Enter and click Yes to UAC popup.
  • Double click HKEY_LOCAL_MACHINE
  • Double click SOFTWARE.
  • Double click Policies.
  • Double click Microsoft.
  • Double click Windows.
  • Click Windows Search.
  • Right click AllowSearchToUseLocation located on the right side and click modify.., change Value data from 0 to 1.
  • Restart computer.

 


  • 0

#15
cigos

cigos

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 127 posts

You have cracked it!   I am much obliged to you for your time and patience.

 

I have learned a little more, thanks to you.

 

Kind regards, Cigos


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP